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Teach-yourself NVivo 7:

the introductory tutorials

Lyn Richards

Welcome to these “do-it-yourself” tutorials for researchers and students who wish to
learn NVivo 7. The ten tutorials are designed as exercises to take you through all the
basic functions of the NVivo 7 software, with guidance to its interface and processes,
as you set up and commence your own project.

There is symmetry between these tutorials and the chapters of my most recent book,
but of course they can be independently used. Each Tutorial explores in software the
techniques and processes described in a chapter of Handling Qualitative Data: a
practical guide, London, Sage, 2005. Those chapters give advice and help with the
research processes the software supports. I wrote the book to help researchers who
need research advice and skills in ways of handling data that have become available
through qualitative software. These tutorials are on the Resources page for that book
on the Sage website: http://www.sagepub.co.uk/richards/.

If you need further help in moving from learning software to getting going in your
own project, a free 24pp handbook, Up and Running in NVivo7 is available for
download at www.lynrichards.org.

© Copyright 2006 Lyn Richards

These tutorials are copyright to ensure that they are not reproduced partially or in ways that distort their
content. They may not be reproduced without permission.

Please contact me at info@lynrichards.org for permission to reproduce them in a research or teaching
situation.
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I have prepared these materials for websites to provide widest possible access to
detailed help for qualitative software self-teaching, a cause I strongly support, and to
allow revision of them as the software changes, (as software does!) with service packs
and new releases. They have been very thoroughly checked by colleagues and testers
at the time of publishing them, and will be revised when further changes in the
software require this.

I particularly wish to thank Daniel Buffett, QSR’s Test Manager, for his very detailed
professional review and comments. Many other colleagues have given me valued
feedback – and more is always gratefully received!

These tutorials are copyright to ensure that if they are reproduced, this is done in
adequate context. Of course permission will be given for copying them in appropriate
contexts.

More information about NVivo
The software taught in these tutorials is NVivo for two reasons: it is the most used
software for qualitative analysis, so the package most normally available for students
and researchers. And it is the software I helped create, design, develop, document and
teach through three revisions. The following links will take you to more information.

For more about the software, resources and information:

www.qsrinternational.com.

For the story of the company, and stages in the software:

http://www.qsrinternational.com/aboutus/company/company_history.htm.

For information about all qualitative software packages:

http://caqdas.soc.surrey.ac.uk.

For my own work, and other writing, and for qualitative research resources:

www.lynrichards.org.

The software used in these tutorials is the latest version of NVivo, NVivo 7.0. QSR
NVivo 1 was released in 2001. The version described in these tutorials was named
NVivo 7 because it is an upgrade path for both NVivo and its sister software, N6, the
current version of the NUD*IST software. NVivo 7 was released end of February
2006. If you are using the previous version, NVivo 2, you will find tutorials for that
version at http://www.sagepub.co.uk/richards/. For those who wish to compare NVivo
2 and NVivo 7, the topics of the two groups of tutorials have been kept as similar as
possible, given new functions in NVivo 7.

If you began work on these tutorials in NVivo 2 and wish to continue in NVivo 7, this
will not be a problem. You can import into NVivo 7 any project from N6 or NVivo 1
or 2 – or, indeed, NVivo 7.

You will need to have a copy of the software to build your own project, using these
tutorials. If you or your institution has no access to a license for NVivo 7, you can still
find how it feels to work in the software by using the free (time-limited)
demonstration version available from the QSR website, www.qsrinternational.com.
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Since that demonstration version is time-limited, don’t download it until you are
ready to commence the tutorials. Note that once its free time expires, you will not be
able to load the free demo again on the same machine, unless QSR provides special
permission.

Data for your project
The exercises for each Tutorial assume that you have data records available to you.
There are many ways of making that data.

The Volunteering data
NVivo 7 ships with a copy of a project called Volunteering, which I created for the
software’s online documentation. Also on the CD are the data sources for that
project. This “project” is about the motivations of those who do volunteer work,
images of volunteers, problems of attracting volunteers to assist organizations. The
interviews are not “real” data – participants were colleagues, and names are not real.
But the ideas and discussions are contributed by real people, many really interested in
the topic, and collated by myself and Kristi Jackson in the US, whose own real
research in the area is documented in the memos in the sample data provided. These
give you the background to what for us became an absorbing project.

You can work with this sample project, if you wish. The files include interviews and
focus groups as well as memos about the project, and you can use them to start your
own project. You might conduct an interview of your own to explore attitudes to
volunteer work amongst your family or friends. Now use the data to answer questions
of your own. The volunteering data will be used in illustrations during these tutorials.

Using your own data
Alternatively, you might make a very small exploratory project with your own data.
For these tutorials you need only a first research question and a few documents – five
hour-long interviews or field note reports would be fine.

You can import existing data from any Word files. Or, if you wish to invent a small
project for these exercises, go to Handling Qualitative Data , Chapter 2 for brief
discussions of some of the many ways of making qualitative data, with references to
other texts for detailed advice. In Chapter 3 is advice on making data records that will
be rich and useful for your project.

Help for Teachers
Teachers using Handling Qualitative Data and these tutorials in their courses are
welcome to contact me to discuss course content and others’ experiences:
info@lynrichards.org.

For NVivo software access and issues of licensing, a Teachers’ Handbook is available
from QSR International, free in a .pdf format. Email info@qsrinternational.com to
request a copy, or for further advice.
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Supporting materials and sources of help
In the following exercises, you will learn very basic use of the software. If you want
to go further with software learning, you will find information, workshops and
personal consultancy in the software are available world-wide.

Like all users of the software, you can find help from many sources.

 The written and on-line documentation of the software – NVivo comes
with a Getting Started booklet. Online Help is available in the software.
Guidance to using Online Help are in Tutorial 1.

 The QSR website, http://www.qsrinternational.com/ has a page on Resources
pointing to readings and materials, and contact details of trainers and
consultants around the world who, like me, use the software and in work in
different contexts and different ways to help others to use it;

 The QSR Forum offers helpful web-based discussion forums answering
questions and providing ideas and research strategies. Go to
http://forums.qsrinternational.com/ to view discussions and register. Click
Calendar to see upcoming workshops and events;

Using these tutorials
The ten tutorials can be followed by individual users working alone, or they can be
incorporated in class laboratory sessions alongside the book chapters. They don’t
explain the purposes of the processes they teach, but refer to the explanations of each
in the chapter of the same number in Handling Qualitative Data.

The topics of the following tutorials are as follows:

Tutorial 1 Setting Up Your Project

Tutorial 2 Creating and Importing Sources

Tutorial 3 Managing data: Cases, Attributes and Sets

Tutorial 4 Editing and Linking: Getting “Up From The Data”

Tutorial 5 Coding, and Working With Coded Data

Tutorial 6 Relationships and Other Nodes: Handling Ideas

Tutorial 7 Seeing It In Models

Tutorial 8 Finding Items and Querying The Data

Tutorial 9 Exploring Patterns in Matrices

Tutorial 10 Reporting and Showing Your Project

I hope the tutorials work for your purposes, and that you enjoy working with them as
much as I’ve enjoyed the challenges of writing them and of developing software to
help researchers do justice to qualitative data.

Lyn Richards,

Melbourne, July 2006.

info@lynrichards.org.



Teach Yourself NVivo 7: tutorials by Lyn Richards 5

Table of Contents
Tutorial 1: SETTING UP YOUR PROJECT 6
1. Meeting the software 7
2. Setting up your own project 8
3. Using Help 10
4. A first step to customizing NVivo 11
5. Your project and its management 12
Tutorial 2: CREATING AND IMPORTING SOURCES 15
1. Choose how you work in NVivo 16
2. Making sources 17
3. Recording external data 20
4. Saving and backing up 23
Tutorial 3: MANAGING DATA: CASES, ATTRIBUTES AND SETS 24
1. Bringing more data into your NVivo Project 26
2. Using attributes and values 27
3. Importing attributes and values 30
4. Using Sets 32
Tutorial 4: EDITING AND LINKING – GETTING “UP FROM THE DATA” 34
1. Editing and undoing 35
2. Annotating sources 37
3. Writing a memo 38
4. “See Also…”: ways of linking to related data. 39
5. Drawing it – the early uses of models 40
Tutorial 5: NODES AND CODING 44
1. Making a node 45
2. Coding at an existing node 47
3. Creating new nodes “up” from the data 50
4. Viewing your coding 52
5. Working with Coded Data 55
6. Auto-coding 58
Tutorial 6: RELATIONSHIPS AND OTHER NODES: HANDLING IDEAS 61
1. Relationships 62
2. Reviewing your nodes 65
3. Rearranging nodes 66
4. Listing and Reporting on Nodes 69
Tutorial 7: MODELS 71
1. Using the model to show the project 72
2. Designing the model 74
3. Hiding and showing groups in a model 76
4. Saving and presenting your model 78
Tutorial 8: ASKING QUESTIONS 80
1. Finding items 81
2. Text Search Query 84
3. Using the results of any query 87
4. Coding Query and Compound Query 90
5. Scoping a query 93
6. Using Query for your project 94
Tutorial 9: EXPLORING PATTERNS IN MATRICES 95
1. Making a matrix 96
2. Using your matrix. 100
3. Saving and exporting the matrix 102
Tutorial 10: REPORTING AND SHOWING YOUR PROJECT 104
1. Keeping a log trail 105
2. Listing and reviewing the project items 107
3. Printing, Reporting and reviewing your sample 108
4. Taking content “out” of NVivo 109
5. Making Reports 110
6. Showing with Models 111



Teach Yourself NVivo 7: tutorials by Lyn Richards 6

NVivo 7 Tutorial 1:

Setting Up your Project
This tutorial is about starting out in software.

Starting out is not a very predictable experience, since many factors affect confidence
and success. These include obvious variables like experience and competence with
computers, familiarity with the purposes of qualitative research and resources of time
and assistance. But none of these is an overwhelming requirement! Success will be
most directly a result of your own efforts to see the purpose of each exercise and to do
it yourself.

The exercises in this tutorial have two purposes: setting up your own project (and
getting familiar with the software) and ensuring you can save, close and open it.

They start with ways of meeting the software through the online resources that come
with it. There are Getting Started self-running tutorials provided, which will help you
to learn how to use the menus, and the uses of the different folders in the Navigation
View.

Following this introduction, there are instructions to set up your own project, and to
familiarize yourself with where your data and reflections will be stored. An
introduction is provided on using Help and customizing the software to suit your
style.

As you work through this first tutorial, take notes of any processes you don’t
understand or want to explore further.

For advice on the early processes of a project, logging the plans and the journey,
entering the field, declaring the assumptions you bring with you, and learning the
software tools you will use on the way, go to Chapter 1 of Handling Qualitative Data.

For assistance with the basic software processes, use the online Help. A section of this
tutorial introduces it.

Note: if you want more advice on the ways of getting into your own project in NVivo,
there is a free handbook, Up and Running in NVivo, available on
www.lynrichards.org.
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1. Meeting the software
At this stage you need an overall familiarity with the tools offered by your software.

If you have access to an introductory class or workshop, this gives the easiest first
encounter with the software. Watching someone who knows it will quickly show you
how to use it.

If you are teaching yourself, use the Getting Started Guide and the Tutorials provided
with the software.

To access the Tutorials:
1. NVivo7 should be installed on your computer. This will be done from a CD or

by download from the QSR website.

2. Start the NVivo application by clicking the desktop icon (or via Start>All
Programs>QSR>NVivo7>NVivo 7). The Welcome screen shows a list of
recent projects which includes the sample project and any other projects a user
might have created.

3. On the menu bar, select Help and then NVivo Tutorials. There are five
Tutorials, which run automatically.

4. On the left hand panel, select the tutorial called Introducing NVivo. The
messages appearing on the screen will explain the basic processes of starting a
project in NVivo.
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2. Setting up your own project
The next task is to set up your project ready to receive your data sources and ideas.

To create a project
1. Whether you just launched NVivo, or just closed a tutorial, the NVivo Welcome

screen is displayed.

2. Choose New Project from the File menu

3. Type in the name of your project and a brief description. Note that unless you
choose a different location, the project will be stored in your “My Documents”
folder. You can change the location of your new project by clicking on the
Browse button in the New Project dialog box. (If you want to move or copy a
project after you have created the project, then you can do this from Windows
Explorer just like any other data file.)

4. Once you click OK in the New Project dialog box, your new project is created and
the NVivo Navigation Window opens. On the title bar at the top of the window
will be the name of the project you created. (In the illustration, it is called
“Exploring Volunteering”).
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Getting to know the Navigation Window
This window will be home base for your project. Its left hand side folders store all the
data items you create or import, and its right side panes list those items and display
their contents. (Currently, there’s nothing there to show.)

If you are using MS Outlook, this window looks very familiar. It’s meant to do so!
For the life of your project, it will be the way you access data items and content.

In the folders on the side you can store all the data and explorations of a project.

As you create data
and start analysis,
there is a place for
each item in these
folders.

The List View of
items, and
information about
them, will appear in
this space when you
click on any folder.

The Detail View of
the contents of an
item will appear
below that list when
you double click on
any item in the list.

Setting up your project, you can
in Sources, put your data documents and memos;

in Nodes, store ideas and coding;

and in Sets, group those sources and ideas.

Then, as your analysis progresses, you can
make Queries to ask questions of your data;

in Models, make diagrams and images;

use Links to connect data items and content,

and make Classifications for attributes and relationships.

And in the panels on the right hand side of the Navigation
Window, you will be able to see and manage the contents of

any folder – listed, or shown in detail.
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3. Using Help
1. Click on the Help menu, this time to access the Online Help

2. Take time to check the Help contents. Note that there are two parts.

 In the sections on Using the Software you will find instructions for conducting
each task or process in NVivo 7.

 Go to the topic on Getting Started and read the subtopics about navigating
NVivo and customizing the workspace.

 The sections called Working with Your Data offer advice on why you would be
doing this, and how to use these tools in your project for your analysis goals.

 Go to the topic on Approaching an NVivo Project. Read about what it is like to
work in NVivo 7.

3. Click the Search tab and try searching for information about some of the processes
you are about to conduct. Note that each topic takes you to information about
using the software and working with your data.
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4. A first step to customizing NVivo
Qualitative researchers often care about the way their data records look, and the
appearance of the screen they are working on.

1. In the Navigation Window, you can change how the folders appear (just as in MS
Outlook) by selecting to show and hide them or see the subfolders all together.

2. You can undock (and re-dock) the Detail View, making it a free-floating window,
whenever you want to concentrate on just one item – to do this, click Docked in
the Window menu.

3. And importantly, you can change whether you see the panels of the Navigation
Window with the Detail View below the List View, or on the right hand side.
Experiment with different layouts especially when you start coding.

4. And yes, you can even change the color scheme of NVivo – and of course any
other application you run under Windows, to fit your preferences by changing the
Windows settings. If you see a colleague’s NVivo in different “livery”, this is
why! Go to Settings> Control Panel> Display> Appearance and choose from
colors offered.

These tutorials and the Help files are in the default color, “blue”.
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5. Your project and its management
Now, to your project. Your NVivo project is stored as a single file. The File menu
allows you to make a new project, open your existing project or close it.
Note the options available from the File menu.

From this menu you make a new project,
open an existing one or import one
project into another.

If you are working in a team you may
later wish to combine your projects in
one. By importing one project into
another, you can merge your work. If you
wish to do this, go for advice to the Help
topics on importing projects.

The File menu also gives access to the
Project Properties. Here you can change
the name or description of your project.

Note, if the name is changed
internally, the project’s file name on your
computer hard disk will not be changed.

To close and locate the project
1. From the File menu select Close Project.

2. If you have made any changes to the project, you will be asked whether you wish
to save this project, choose YES.

Congratulations! You have a new, saved project, waiting for your data and ideas.

Your NVivo project database is saved in a single file. By default it is in the My
Documents folder. (If you changed this default, or move it at any time, be sure to
record where you placed that file.) Your new project should now be stored in the
location you specified.

3. Go to the Windows Explorer and the folder for My Documents to check your
project is where you put it. It is a single file with the NVivo 7 icon and the
extension .nvp (for “NVivo project”). Like any other file it can be copied, moved
or sent to a colleague.

To open and save your Project
1. When you closed your project, you returned to the Welcome window, which now

shows the name of your project. Click on its name. Your project will open in the
Navigation window.

Note that on the File menu, Save Project is probably not available, because you
have not made any changes to save.
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2. From the File menu, select Project Properties. The window tells the name and
description you gave your project, and the time you created it. Alter the
description to add detail. Now, you have made changes and can select the Save
Project option, or simply use Ctrl+S.

Make a habit from now of doing a Save whenever you feel you have significantly
changed your project.

To manage saving and undoing
NVivo has Undo – more on how to use it below. After you save changes, they cannot
be undone. For this reason, NVivo will not “autosave”. Rather, it will ask, at regular
intervals, if you wish to save. (You can change the frequency of reminders – see next
section on Options). Always consider your answer, as you may wish to Undo
something you just did.

When you close a project, if any changes have been made to it, NVivo will ask you if
you wish to save changes.

To back up your project file
There is great advantage in having your project saved as a single file. It is much less
likely to be damaged by bad file management than a project saved in many folders.
Also, you can easily send the entire project to a colleague or supervisor as an
attachment to an email. If it gets big, compress the file using Winzip.

You back your project up like any other file.

When you wish to back your project up

 use whatever is your normal backup procedure to make a copy of the
project file on another safe storage device;

 or if you prefer, make a copy of a project from the Welcome window
in NVivo. (Simply select File>Copy Project)

Always back up your project frequently, and keep a record of where you stored the
backup copy, and of other relevant information about date, state of project at backup,
in case of computer problems or change of direction in your thinking. When you are
working qualitatively, you can change the project data base very many times in so
many minutes! Like any computer file, your project can be deleted or mislaid if you
are not careful with your data management processes.
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To set application options for save and safety
1. From the menu bar select Tools>Options. The Application Options window

opens. Set the project save reminders to the time you prefer.

2. Click through the tabs to check the range of project options you can set.

Big Warning! one option is Enable deletion confirmation messages. Unless you
are very confident, don’t un-tick it!! For most users, it is essential to have that warning
when, unintentionally, they have asked to delete items.

3. Note the final button will Clear Recent Project List. You’ll be needing this!
Use it when you wish to clean up the Welcome Window’s list of projects after
you remove experimental old projects, or move ones you are working on.

This concludes NVivo 7 Tutorial 1. Go to Chapter 1 of Handling Qualitative Data
for advice on any of these research processes..

Now for some data! In Tutorial 2, you’ll make documents in three different ways –
and back up the now growing project.
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NVivo 7 Tutorial 2:

Creating and Importing Sources
This tutorial is about how to make data records in NVivo7, or import them into your
NVivo project. There are three ways of doing this – in this tutorial there are
instructions for each. You will:

 import one or more records from a word processor file;

 work in your project, and create a record there;

 record a summary of what’s in an External record.

And since at the end of this tutorial you will have a project underway, it concludes
with instructions for a fourth task:

 back up this precious project file that records your work!

Chapter 2 of Handling Qualitative Data is about making qualitative data, the many
ways of doing so and how to make useful data for your purposes. To review what you
need to know about documents, go to the Online Help.

About sources: documents, memos and externals
NVivo provides three folders for three sorts of Sources – documents, memos and
externals.

These are common divisions in a qualitative project. You can make further sub-
folders of your own to hold different types of Sources. Documents, for example, may
be divided into interviews and focus groups, or memos into theoretical and
methodological notes.

If you are working in NVivo you can write early research design records or letters etc.
in a word processor and import them to your new project as documents or memos. Or
simply write them within your project.

And you can make “External” sources to represent other material that you will not
bring into the project at all but don’t want to lose.

This tutorial takes you through the steps to import a source, to create a source in
NVivo and to create an External to record other data.

As you work through these steps, note that there are always at least two ways of
getting to the commands you wish to give the software. Familiarity with these
different ways of working with software will help you find the way that suits you best.

Use the List View, as you work. Like the familiar Windows Explorer, it will allow
you to sort on any of the columns in the right pane. As you bring in more sources, you can
view your documents or externals in order of size, amount of coding, or date created or
modified.
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1. Choose how you work in NVivo
Most tasks can be accessed via the top level menu and also the context menu available
from the right-mouse button. For most menu items there are short cuts. And for some
there are icons on the tool bars. For example, there are always three ways to add any
new item.

You first need to tell NVivo what you wish to add. You do this by clicking on the
appropriate folder, and then clicking in the right pane List View. Now what you can
do for that sort of item will show on the Project Menu and the Context menu when
you click the right mouse button.

1. Go to the Project menu and
you will find it offers the
option to create a new item
of that sort (or, for
documents, import them).

2. Or right click in the List
View and from the right
mouse Context menu
select the option to add a
new item of that sort (or,
for documents, to import
them).

3. Or just use the New button
to create this sort, or any
other sort of new project
items.

Have you noticed that most
common actions in NVivo 7 have fast
keys showing with the menu items?
It is useful to learn the ones you
will often want to use.
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2. Making sources
Most of the data sources in most qualitative projects are recorded in text. At this
stage, you may have early research design documents. Later, you will add transcripts
of interviews, field notes, survey responses etc.

As those documents are created, they are usually typed up in your normal word
processor (here we will assume it’s MSWord.) These word processor documents can
be imported directly into your project in NVivo. They can be in Word files (.doc) or
in rich text format (.rtf) or of course in plain text (.txt). If you use Word files, they can
include pictures or tables or other embedded objects, and you will be able to view,
code and retrieve this content.

To import a document
1. Create a document in your word processor, or locate one you have already typed

up. Or write an informal one about what you are planning to do and call it
something like “Project Journal”. Save it as a Word (.doc) file, in a sensible
location.

2. In your NVivo project, click on the folder for Sources, and then Documents.
Click in the List View to show you want to work with the items in that folder.
From the Project menu select Import Documents. (Or select this command from
the context menu when you click your right mouse.)

3. Note the options offered. The option to Code sources at cases is covered in the
tutorial for Chapter 3. If you are importing documents (e.g. interviews) that
represent cases for which you want to store information, go to that tutorial
to read about cases.

4. Click Browse to select the file to import. Navigate to where your first source file
is located. Select it, and click Open. (If you have prepared more than one
document, select with Ctrl+click or Shift+click to import many documents at
once.) Click OK.

5. The Document Properties are shown. By default, the name of the document is
the name of the file selected. You can rename or re-describe the document at any
time by going to its Properties.
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6. Click OK. Your document is imported and its name and details appear in the List
View. To read it, double click on the icon next to its name, and its contents will
open in the Detail View below.

If you wish, you can edit the text, cut and paste text or images, change colors and
fonts etc just as though you were in a word processor. Close the Detail View at any
time by clicking on the X in the top right corner of the detail view.

To add a new source in NVivo’s editor
Documents or memos can also be introduced into a project by transcribing directly
into NVivo. It has a rich text editor, with font controls, and Undo. (Though of course
it does not have full word processor functions like spelling checkers.)

Now consider a memo you wish to start. Perhaps a record about your own attitudes
(prejudices?) to what you are researching? This may be a first important contribution
to your project’s logging process. Once it’s created in NVivo you can continue to
enter into it all the changes in your views (or confirmations of them) that should be
logged.

As you’ll see in later tutorials, there are huge advantages in typing directly into
NVivo. Any log trail document can be linked to the data it describes and you can code
as you type. But for now, just start it.

1. In the Navigation window, click on the folders for Sources and then Memos.
Remember to click in the List View to tell NVivo you want to work with the
items in that folder. Now you can use the menus as before: click Project>Add
Memo or use the context menu or the New button.

2. In the New Memo window, name and optionally describe your memo.

Descriptions matter! NVivo gives a description option for most project items.
Always use this if your purpose in creating an item (like a memo) may be forgotten or
confused. Teams are much helped by storing descriptions to convey purpose.
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3. Click OK and the memo is created. The content (currently none) opens in the
Detail View Type on… you are in NVivo’s rich text editor so use heading styles,
italics, bold or color as you wish. (Advice on starting a Log Trail document is in
pp. 43-44 of Handling Qualitative Data.)

4. It’s important to date the entries in any project log. Note that you can time-stamp
your entries by selecting Format >Insert> Date/time, or just hitting
Control+Shift +T.

5. Close the memo as you would in a word processor, by clicking the corner X in
the title bar. Changes will be automatically saved.



Teach Yourself NVivo 7: tutorials by Lyn Richards 20

3. Recording external data
Now for data that is not easily brought into NVivo. As noted in Chapter 2, qualitative
data records are rarely homogeneous. Much of your data will not be textual.

For the project you proposed, find some data that you do not want to bring into the
computer, or can’t – e.g. books, photos, a video, or a box of newspaper cuttings. In
NVivo, such data can be represented by “Externals”. If the data represented is a file
on your computer it’s called an “external file” because it will not be in your project.
If it’s not on your computer, it’s termed non-file data.

To add an External for a book
If you are stuck for some external data, make an External for Handling Qualitative
Data. Any project requires work with literature, and with an External you can
reference and keep connections with books and articles. Your summary of each
chapter, with occasional quotes, is a Source for the project; you can link it to relevant
data in your project and use coding to find the passages when they are needed.

The process of creating a new item should be familiar now – select the folder you will
create it in, (Sources and then Externals) click in the List View to show you want to
work with the items in this folder.

1. From the Project menu (or the context menu), choose Add External (or use the
New button: New>External in this folder).

2. Type in the name and any relevant details.

3. Click the External tab to specify the file type – this can be a file link or web link.
If you are describing something (like a book), that is not a file on your computer
or a URL, select Other.
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4. If you wish, specify what the contents are, the unit (e.g. chapter) and the range
(e.g. chapters 1-10).

5. Click OK. Your External appears, ready for you to type in summary or comments.
If you asked for numbered units, you have a template into which you can type the
summaries of your external data. Each chapter (or other unit that you’ve specified)
has its own paragraph, so you can put the summary or your comments at the
appropriate place.

6. As before, just type as though you were in a word processor, changing styles,
fonts, etc as you wish. You can insert hyperlinks to a website or images from the
book. In the later tutorials to Chapters 3 and 5, you’ll learn how to link and code
this different sort of data.
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To add an external for a website
This is a very common requirement – you have found a site and wish to keep the link
to it and record your notes on the content. Make an External for that website and you
can at any time jump to the site from your NVivo project.

1. You’ve found the website and copied the URL. As above, Add External. Type in
the name and description.

2. Click the External tab to specify the type and location of this source. Contents or
units are not relevant for a site – simply leave these options. Click OK.

3. The External opens in the Detail View and you can type your summary or
reflections. You can copy and paste images into your External if you wish.

4. From the List View you can at any time Open External File – (from the Project
menu or Context Menu). This calls the website (if your computer is connected to
the web).
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4. Saving and backing up
A reminder: NVivo 7 has saved your project in a single file. This single file can now
be stored on a CD, Zip Disk, Network drive or emailed to a supervisor or colleague.

1. Save and Close your project.

2. In the Welcome Window, select File>Copy Project and follow the directions
to make a copy of your project.

OR

3. Find the project file in your My Documents folder, and make a copy of the
file.

4. Now, save the copy somewhere other than on your computer hard disk, for
backing up.

You haven’t created a secure backup until this backup file is copied elsewhere. A
backup on your hard drive is a copy not a backup – reflect on what happens to it if your
hard drive dies or your computer is stolen.

This concludes NVivo 7 tutorial 2. Got to Chapter 2 of Handling Qualitative Data for
advice on any of these research processes..

You now have a project with data, and a good routine for keeping it safe! In the next
tutorial, you’ll learn how to store different sorts of information.
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NVivo 7 Tutorial 3:

Managing data: Cases, Attributes and Sets
For most new researchers an early concern is to learn the ways data are recorded. One
aspect of this process is to store the context and the sometimes complex information
that you have to accompany the qualitative data sources you are gathering via
discussions, interviews or field notes.

In NVivo, you can store such information as Attributes of your cases, that is, the
sites or individuals you are studying.

In this tutorial you will learn how to

 make case nodes to gather all the material about a case, and create the relevant
values of variables, such as gender = female;

 create attributes and store the values for cases in NVivo;

 import a table of attribute values;

 and “tidy” sources and nodes into Sets.

Chapter 3 of Handling Qualitative Data is about the importance of making good data
records, storing the information about cases which may be essential for your analysis
and managing the data records.

For more detail about Attributes and Sets, go to the online Help.

Thinking nodes and coding
Nodes are containers for categories in your project, ideas or topics you are interested
in. They can store references to data segments about any topic or concept. So they do
what for most researchers is a most basic task of all qualitative projects – bringing
together the relevant data content for a question or reflection.

You gather data together by coding those segments at a node. You can then view and
review all of the data coded at a node.

Nodes and coding are the subject of the next tutorials. Most of the coding you do at
nodes will be interpretative – recording your interpretation of the selected data and
gathering everything about a topic at a node.

But nodes also have many important data management roles. They can hold all the
answers to a particular question or store all the results of a query. And most
obviously, they can hold all references to data about a case. In NVivo 7, any case for
which you wish to record attributes is given a Case node.

In the previous tutorial, when you imported documents, an option was to Code
sources at cases. If you are importing documents (e.g. interviews) that represent cases
for which you want to store information, you simply select that option and the whole
document will be coded at a case node with the same name.
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Cases as data containers
In the Navigation Window, the second folder is for Nodes. This has five folders for
different sorts of nodes. One of these is for Cases. In that folder, you can make new
items. A new case will be represented by a node.

Sometimes, a case is represented by all of and only one document (for example in a
project where interviews were conducted just once with each person). But this is
unusual in qualitative research. More often, you have material about a case from bits
of many sources, (a joint interview with a colleague, field notes on a meeting, bits of a
focus group). To gather all that material about the case, you code it at a Case Node.
Then you can see it all together and ask questions about it. You can also store
information about the attributes of that case – e.g. this is a female, unemployed. Then,
when you wish to find what unemployed females said about an issue, NVivo can
locate all of the data coded at cases for which gender (attribute) = female (value).

To design cases for your project
For your own project, ask, “What is a Case in this project?” Try these ways to the
answer:

 What is the project about?

 What places or institutions or individuals are you asking about?

 What classifications are relevant? What sort of information do you
want to store, and what cases have that information?

Almost always these questions focus the study. If you are comparing schools,
according to their socio-economic status and staffing profiles, schools are cases for
this study. Code all the material about each school at its case node, and store there its
attributes. Now you will be able to ask the comparative questions. (Did staff of
working class schools have different attitudes to discipline?)

As you build more data about a school, you can code it at the relevant case node. The
attributes recorded for that node will automatically apply to the new material.

You can arrange cases in sub-groups, each under a more general case node. (A good
design in the Sample Project would be to make case nodes for “Focus Group Participants”
and “Interviewees”. And perhaps to have another node for cases of “Companies” working
with volunteers.)
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1. Bringing more data into your NVivo Project
To start this tutorial, prepare at least two more data documents, each of which
represents a case, for example transcripts of interviews, each with one person. If you
have no such data records yet, create documents from other sources, like website
descriptions of relevant people.

To import documents and create case nodes for them
1. Import more documents into your NVivo project, following the instructions in

the previous tutorial.

2. At the Import Source(s) window, click the option to Code sources at cases.
for any document for which you want to store attribute values.

(If you want to put these new nodes under case nodes for each type of case, click
Select and select the node, e.g. “Interviewees”, “Focus Group participants”,
“Companies”).

3. Click Browse to locate and import the source(s). In the Navigation Window,
they appear in the Documents List View.

4. Go to Nodes and click on Cases. You have a new case node for each
document (with the same name as that document). Click on a case node to see,
in the Detail View what is coded there. You have coded at that node the entire
document.

Now that you have a Case node, you need not restrict the material on this case to just
one document. When you later get more data about that case, you can code that data at
the Case node. But for now, the task is to store information about the attributes of that
case.

Note how often Attributes appear in the menus and dialogs. If you store
information about the attributes of cases, this information will be useable in all Queries,
“Find” processes and Reports.
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2. Using attributes and values
If you know the attributes your respondents or sites will have (that is, the information
you’ll want to store about them), you can create them all now, with their values. But
there is no need to – attributes and values can be created as needed. You can
individually create attributes and allocate the appropriate values in NVivo. Or, if you
have substantial amounts of this type of information (e.g. in an SPSS or Excel file) it
can be imported as a table.

To create attributes and values
1. In the Navigation Window, select Classifications>Attributes. Right click in the

List View. From the Project menu, (or the Context menu, or the New button)
select New Attribute. The New Attribute dialog box is displayed.

2. Type in the name and, unless it is absolutely obvious what you are recording, a
description of this attribute.

3. Select the attribute Type (string, number or date) from the drop-down list.

4. Click the Values tab to define the values for the attribute.

5. To add each new value, click the Add button and enter value name and optionally
description.

6. Check the Default checkbox to specify which value will be allocated to new cases
as a default (unassigned is usual.)
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To assign Attribute Values to Cases
If you know the information about an individual case, you can easily store it, or at any
stage change it.

1. In List View, select the required case. From the Project menu or right mouse
context menu, click Case Properties.

2. Click the Attribute Values tab and from the drop down menu for each
attribute, choose the relevant value. Click OK.

To view and use the Casebook
Information about attributes is best displayed in a table. NVivo shows the Cases you
create, and their values for each attribute, in a table called a Casebook. You can
view the Casebook, import a table to it or export from it the information stored so far.

1. From the Tools menu, select Casebook>Open Casebook.

2. The Casebook appears in the Detail View. It may look very small if you have
only one case with only one attribute! But as your data builds up it will fill up.
The Casebook for the sample project looks like this. You can print it.

3. Using the filter icons, you can change which rows appear. For example, to see
only the under 40’s in your sample, filter on the column “age group”:
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4. Case characteristics can be changed, when you get more information, or
perhaps the circumstances of people are altered. At any stage, you can alter the
value shown for any attribute of a case.

To alter it to an existing value, select from the drop down list.

To create a new value for a case, select the value in that cell and edit it – if, for

example, Anna just graduated!

Note that long names of attributes and values will be shortened in the Casebook –
for efficiency, keep them as short as possible.
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3. Importing attributes and values
You can import information to a casebook from any program that handles tables (a
spreadsheet, data base, statistics package, or just a table you make in MSWord.)

An attribute table can be created “outside” NVivo and imported. You can create it by
exporting attributes from a statistics package or spreadsheet. Or you can type up the
table in spreadsheet or word processor software. If you have a lot of attributes and
documents, this is more efficient than creating them in NVivo.

Please check the Help files for more detailed advice on the formatting of tables and
the format selected for import

To create a table for import to a casebook
1. Type a small table in any program that will create a table (e.g. Word or Excel),

with the names of your cases down the side. The top left corner cell can be blank,
or have any word in it (such as Schools or Interviewees).

Make sure that the case names are the same as the names of case nodes in the
NVivo project that you want to give these attributes to. If a case name is not
recognized, NVivo will optionally create a new case node for it. If you don’t yet have
those case nodes in your project, this may be what you want to do (it’s a quick way of
creating case nodes). But if you have them slightly different, you’ll get a lot of nodes!

2. Type names of attributes as the headings of the columns. (Keep them brief.)

3. Type into this table the names of the values for each case, under each attribute. If
the attribute isn’t applicable, leave the cell blank.

You will have a table that looks something like this (start small for a first try).

Gender Age Income

Interview 1 Female Under 20 None

Interview 2 Male 20-30 Middle

4. Save that table in your table-making software, selecting the options for cells to be
tab-separated, and the “encoding” to be Unicode Text (*.txt).

If you prepared your table in Word, check that there are no blank lines above or below
the table, then on the top menu go to Table>Select>Table, then
Table>Convert>Table to Text and choose Tabs for separation.

Now select File>Save As and from Save As Type and Plain Text (.*txt). When you
close the window, Word asks you to specify File Conversion. Unclick the Windows
(Default) and instead choose Other Encoding and scroll down to select Unicode.
This matches the default setting for importing Casebooks into NVivo

Or: if you leave the File Conversion at Windows (Default), the table will import so
long as you change the File encoding setting in NVivo to US-ASCII.

5. Save it somewhere you will find it again!
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To import a table into your Casebook
1. If you are unsure what you are importing, find and open the file you saved as plain

text. It looks a lot less tidy than in its table format. But it has the same content as
the table you saved. The cells are marked by tabs rather than neat lines. This is the
version that NVivo can import.

2. In your NVivo Project, choose Tools>Import Casebook.

3. Click Browse to locate your tab
separated table.

4. Check that the File encoding
setting is correct for the table you
saved.

5. Check the Options. You can ask
NVivo to

 overwrite existing values

 create any attributes or
cases your project doesn’t
contain.

6. Click OK. Now open the Casebook and check what you’ve done.

If the values didn’t appear as specified in the table you imported, it’s probably
because you created those attributes prior to import, giving default values (usually not
applicable) to the cases. If you didn’t ask to overwrite existing values, these will remain.
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4. Using Sets
This tutorial finishes with the simplest way of managing your data records in NVivo,
by grouping sources and/or nodes in Sets.

Whilst Sets are very easily made and used, they are also very effective quick ways to
gather data in groups and ways into the most subtle and powerful searching processes
(see Chapter 8).

To make a Set
There are many ways to create a set in NVivo and add items to it. Whichever you use,
what is added is a shortcut to the items you select.

1. To make a new, empty Set, click in the Sets folder in the Navigation
Window, click on Sets.

2. Select (from the Project menu or Context menu or the New button) New Set.

3. Or, to make a new set with items in it, or add items to an existing set, go to
the List View for those items (either sources or nodes) and select them. Then
from the right mouse Context menu select or Add to Set or Create As Set.

4. Check the contents of a set by clicking on it in the Sets folder; the sources or
nodes you put in it will show in the List View. Note, the icons are different –
these are shortcuts to the item. So you can put a source or a node in any
number of different sets.
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5. As a final exercise for this tutorial, think of useful ways you could group your
documents and nodes for your project’s purposes. In the example above, the
researcher created a set for all coded sources – a useful way of checking
whether coding is proceeding as planned.

For most qualitative projects, a useful set is of documents and/or nodes coding
content that will contribute to your “log trail”, your growing account of the project
and how it is conducted. Visit the final chapter of Handling Qualitative Data to read
about the task of doing a “stock take” of your writings about the project. This will be
much easier if there’s a pointer to each relevant document in a set called “Log trail
documents”.

This concludes NVivo 7 Tutorial 3.

Got to Chapter 3 of Handling Qualitative Data for advice on any of these research
processes.

You now have a project with data documents and information about their context, and
have started managing those records in sets. Time to back up.

In the next tutorial, you’ll learn skills for discovery and handling of the ideas that
come from the data.
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NVivo 7 Tutorial 4:

Editing and Linking – Getting “Up From The Data”
In this tutorial, you will work with just one document in your project, to explore the
processes of “taking off” or “getting up” from the data. As you read the record, and
discover new ideas, you will try different ways of storing these in software.

In Tutorial 5, the processes of coding will be described. Normally, researchers
combine the storing of ideas with the creating of categories and doing coding – but for
early steps, it is useful to take them separately. In the following exercises you will:

 Edit a document

 Annotate it.

 Write about it in a memo.

 Link it to related data.

 Draw your first ideas in a model.

The first section of this tutorial, on editing, contains an introduction to the toolbars
and icons that give access to NVivo’s processes. Unless you are very familiar with
using toolbars, you will be helped by familiarizing yourself with the shortcuts and
quick access routes to tasks you may wish to do often.

Remember, there is almost always a choice of ways of asking NVivo to do something.
As a reminder to select the processes that suit you best, the alternatives are noted in
this section, in blue.

Chapter 4 in Handling Qualitative Data is about the exciting processes in qualitative
research involving discovery and exploration of ideas from the data.

To review what you need to know about the different ways of storing ideas and
different sorts of links, go to Help.

Focusing on a document
To start this tutorial, select a document you already have as a Source in your project.

Print it out or browse it on the screen, and really read it. Make notes about it as you
read.

Now, go back to the start of that document. This time read the text very thoroughly,
line by line. (As you find material that is interesting, conduct the exercise on “Taking
off from the data” in Handling Qualitative Data, pp. 70f. In turn, the following
exercises use each of the ways of storing ideas about the document discussed there.)
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1. Editing and undoing

To edit a source
1. In the List View, create or select the document you wish to edit. Double click

to open it in the Detail View below.

2. This window allows you to write text, delete and edit it, as well as to annotate,
create memos and (see next tutorial) code.

3. Do some editing. The easiest way to create, add to or comment on the content
of your data records is of course to edit them. You edit in NVivo very
similarly to editing in a word processor.

A note on toolbars
If you are familiar with your word processor’s toolbars, or those in Outlook, you will
find NVivo’s have icons for the same main processes and you can manage them
similarly. Check the special NVivo functions and icons and then move to the next
section!

But if you are not used to using toolbars, take time to make these suit you. Qualitative
research involves a lot of writing. Check that you know what each icon represents, by
hovering over them. The Main toolbar has familiar icons for cut, copy, paste options,
and importantly, Undo! (You can view all the icons and what they represent in the
Add or Remove Buttons list.)

These main menu options will apply to many processes, not just editing a data record.
You can cut and paste a node, for example, or undo a change to a model.

Clicking the Undo icon will undo the most recent
process. Clicking the dropdown arrow beside the Undo icon will
show the last five processes you conducted. Select any to
undo back to the selected process.



Teach Yourself NVivo 7: tutorials by Lyn Richards 36

The Edit Toolbar has icons for familiar word processing tasks. The first slots on this
toolbar set text styles, font and font size. You may wish to make the toolbars shorter
and use short cuts instead of icons. To do so, from the Add or Remove Buttons list
untick any options you wish to hide. (As above, you can view the icons with their
names by pulling down the Add or Remove Buttons list.)

From the first slot on the Edit toolbar you can set the style for your text.

If you use Headings when typing sources in Word, they will be
imported with the source to NVivo.

By setting heading level, you give NVivo information that allows
it to show and autocode the content between headings.

Click Customize at the end of any toolbar to hide icons you don’t want to use. But
first check what they offer you!

There are four further Toolbars specific to NVivo’s processes, Coding, Links, Grid
in tables, and ways of Viewing the data. Check how they represent items in the menus
– those most commonly used.

You can drag the toolbars, as in Word, to relocate them (with their identifying
names).

For the next section, on annotating, try using the icons on the Links and View
toolbars.
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2. Annotating sources
Editing a data record is not always a desirable way of recording your ideas. If this is a
record of an interview transcript, or a letter, you are unlikely to want to alter it with
your comments, or distract from the voice of the respondent. For such commentary it
is preferable to add an annotation that is linked to the text but does not interrupt it.
Annotations can be searched using Find or Text Search Query, and when you do
coding, your annotations will be kept live with coded text.

Words in an NVivo annotation cannot be separately coded. So use annotations for
ideas that belong with the text annotated. A “bigger” idea or interpretation requires a
memo – whose content can be coded like that of any other source.

To add an annotation:
1. In the Detail View, select some words that require an annotation.

2. From the context menu select Links>Annotation>New Annotation.

OR go to the Links menu, or on the Links toolbar, click the New Annotation icon.

3. The selected text is highlighted. An Annotations tab appears at the bottom of
the Detail View. Type your ideas…

4. Make more annotations to this source. (Note any selection of text can have
only one annotation). They will appear, appropriately numbered, in the tab.
You can always go to an annotation to edit or delete it. And when you print
the source, you can have annotations printed as endnotes.

5. If you wish to hide your annotations, while you work in the Detail View, go to
that View toolbar (or the View menu) and unselect View Annotations.



Teach Yourself NVivo 7: tutorials by Lyn Richards 38

3. Writing a memo
There is an emphasis in all qualitative methods on using memos to capture thoughts
and insights you have when you are working through your data: ( see Handling
Qualitative Data, Chapter 4.)

Memos are full status sources in NVivo. The program sees them differently from
other sources only because you label them as memos. (The tutorial for Chapter 2
suggested a first memo called “Volunteering and me”. If you made that, it’s a memo
simply because you put it in the memos folder. If you are using the sample data, you
will find several other memos in the Data folder for importing.)

Any source – including any memo – can be linked to the content of any source. More
on these “see also” links below.

Any source or node (with one restriction) can have its “own” Linked Memo, linked
directly to that project item These memos, “owned” by a document or node, are
optional, provided for the reflections on just that interview or concept.

The restriction? A Linked Memo can’t itself have another Linked Memo. (This
restriction protects you from endless tangles!)

To make a Linked Memo for a source or node
1. In List View , select the source or node for which you want to create a memo.

2. From the Links menu, choose Memo Link >Link to New Memo

Or right mouse to get the same options on the context menu.

3. Name and describe this new memo, (as shown in Tutorial 2), and write your
thoughts. Remember to insert date and time. Note that the sources that have
linked memos show icons for these in the List View.
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4. “See Also…”: ways of linking to related data.
Qualitative research does a lot of linking – as in most interpretative work, the
researcher is often wishing to say “See also the data to be found…” (Handling
Qualitative Data, pp 75-6). Now the data records are becoming “richer”, with your
own ideas and the links to related material.

NVivo provides a range of ways of linking for this purpose. As you reflect on your
data document, you may wish to place a See Also link to a new item, to particular
words or images in existing data items or in a file that is on your computer (in any
other software) or a website. Here we will show the first two of these. Explore other
options using the online Help.

You can make Memos that are not directly linked to an item, to record your growing
ideas about themes and concepts that you want to go back and explore later on. You
can also of course keep those ideas in a notebook. But unlike the notebook, they can
be linked directly to the text that gives you an idea, or the place you store it. This will
matter when you wish to report and log the way you developed your analysis.

To link from content of a source to a new or existing project item
1. Open a document in your project. (Or any memo, external, or node).

2. Highlight some content you wish to link from.

3. Right mouse click and choose Links>See Also Link>New See Also Link.

Or get the same option from the Links menu, or on the Links toolbar, click the New
See Also Link icon.

4. In the New See Also Link window, specify what you want to link to. If it is a
new document or memo, this will be created and opened.
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To link to particular content of an item
If your Option is to link to an existing item, you can select either to link to the whole
or link to particular content (this is often more useful).

1. Select to make a “See Also” link to Selected Content. Click Select.

2. NVivo will open that item in a new window. Select the relevant content.

3. At the bottom of the window, click Select, then in the dialog, click OK. The
link is made.

Note, you can make a link to selected content in the same document, useful if for
example the speaker changed their mind on an issue later.

To open the “to” item
1. At any stage, you can go to the text you linked to from the anchor, now

marked by a red wavy line under the text from which you made the link.

2. Click in that anchor, and right mouse to select Links>Open To Item.
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5. Drawing it – the early uses of models
Throughout qualitative research, models are widely used, with many ways of
representing hunches, discoveries and theories. (Go to Handling Qualitative Data
Chapter 4, pp 76f, for suggestions for first uses of simple models as ways of sketching
and exploring what you think you are seeing in the data.

You may wish to explore these techniques more fully by jumping to the discussion of
NVivo’s model tools in the tutorial for Chapter 7. Here, the goal is simply to become
aware of the possibility of modeling your emerging ideas.

To start a first model
Models are made up of shapes and connectors. You start a model by adding these to a
blank “sheet”. You add new models just like any other project item – from the List
View, using the Main Menu (Project menu), the New button or the right mouse
context menu.

1. In Navigation View , click the Models button and click in the List View.

2. On the Project menu, click New Model.

3. In the New Model dialog enter a name and if you wish, a description. Click
OK. An empty model is displayed in Detail View.

4. Now add either empty shapes or project items to the model. There are many
ways to do this: copy/paste, drag and drop, or use the Model menu or right
mouse context menu.

5. To connect two shapes, select them both and from the right mouse Context
menu select New Connector.

6. If you add Project items to the model, they are “live”: double click on them to
open them in Detail View.
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Shaping and changing the model’s appearance
Appearance does matter, when you are drawing a model to show (to yourself or your
colleagues) what you are seeing in your project. But beware of how much time you
can spend on cosmetic touches!

1. To name your shapes and connectors, double click on them to go to their
Properties.

2. To color lines or fill shapes, go to the edit menu.

3. Select a connector, then from the Format menu that appears, select Line

and you can give your connectors style, weight and color.
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Customizing the model space
A final exercise in using the software concludes this tutorial. Use the menus to
customize this modeling space to suit you. Models are a clear case for maximizing
your screen “real estate”.

1. Remember that you can undock the Detail View - click Docked in the Window
menu. Now maximize the undocked window, to have your model able to take
up the whole screen .

2. From the View menu, select to
hide the panels to left and right of
the model – the Model Shapes
Palette and Model Groups.

3. You can also Zoom in or out on
your model.

This concludes the NVivo 7 Tutorial 4. You now have data, ideas about your data
and a rapidly growing project. Remember to back up the project file after you exit this
tutorial! Go to Chapter 4 of Handling Qualitative Data for advice on any of these
research processes.

For most researchers, at this early stage in a project, the next task is to start gathering
material according to topic. For this purpose, you need to code. If you are unfamiliar
with qualitative ways of coding, go to Handling Qualitative Data, Chapter 5. In the next
tutorial you’ll learn many ways of doing coding in NVivo.



Teach Yourself NVivo 7: tutorials by Lyn Richards 44

NVivo 7 Tutorial 5:

Nodes and Coding
Nodes – the containers for ideas and coding – should be familiar by now. They were
explained in Tutorial 3, where the exercises created nodes to hold references to all the
material about a case. That tutorial also taught one sort of “descriptive coding”, the
storing of attributes (e.g. gender) and assigning of the relevant value (e.g. female) to
each case. Revisit that tutorial for techniques of doing this manually or by table
import.

But when qualitative researchers code, they are usually doing something
interpretative, not merely descriptive. This tutorial shows techniques for doing
qualitative coding. It introduces ways to create the categories for thinking about your
data, to identify new categories and ideas from the data, and to gather material about
those ideas.

In it you will learn how to:

 Create nodes from prior ideas;

 Code at existing nodes;

 Create nodes and code “up” from meanings in the data;

 Create and name new nodes “in-vivo”, from the words in the data;

 View coded data and its context;

 Work with coded data, coding on to other nodes;

 Auto-code data records that are structured, using headings.

For advice about creating categories and coding, explanation of the differences
between qualitative and quantitative coding and the purposes for which qualitative
researchers use coding, go to Chapter 5 of Handling Qualitative Data.

For more detail about coding processes in NVivo 7, go to the online Help.

Focusing on a document
To start this tutorial, as with the previous one, you need to concentrate on one
document in your project.

It may be the document you worked with in the previous tutorial; it’s interesting (but
not necessary) to combine writing and linking techniques with those of coding. If you
want to move to a different document, read it through before you begin coding on
computer Now, go back to the start of your document.

The simplest goals of coding are to identify the categories for thinking about your
data and to gather at a category all the data about it.

In these examples, the document is one of the interviews in the sample project on
Volunteering, the interview with “Anna”. You can conduct these exercises with any
source (document, external or memo) in your own project.
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1. Making a node
Where do the categories for thinking about your research come from? Researchers
coding in qualitative research often create categories, “down” from their research
questions and designs, before they start exploring the data. In NVivo, those categories
and the coding you do are stored at nodes.

The node areas
In the Navigation View, click Nodes to view the different areas for nodes.

These provide folders for:

 nodes “Free” of organization
 nodes in catalogs or “Trees”

 Cases (see Tutorial 3)
 nodes for coding Relationships

 Matrices (see Tutorial 9)
 and to see nodes all in one list,

All Nodes.

The next tutorial covers Relationships and the managing of nodes in trees. Here
you will code just at Free Nodes.

To make a node
6. Using a memo or model in NVivo, or if you prefer, paper, or a white board,

sketch a beginning list of the categories your project is about – topics or ideas
about which you wish to collect data. (For example, in the Volunteering
project you might be curious about what motivates volunteers or the images of
volunteering.)

7. Click on Free Nodes. And click in the empty List View.

8. Just as for making new documents, there are many ways to make a new node.

 From Project menu OR Context menu, select Create a Free Node.
 OR use the New button, to create a New Free Node in This Folder.
 OR use the fast key, Ctrl+Shift+A.

9. Name the new node, and if you wish, add a description.
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10. Check the information in the List View. Note that the node is showing that it
codes no Sources and (not surprisingly!) has no references to content. It is a
useful habit to scan the nodes you create, watching for the ones that show no
sources coded there, and wondering why they don’t have coding.

11. Continue creating and naming nodes for any broad topics or concepts you
expect that your project will require. If wish to change the properties of a
node, select Free Node Properties from Project or Context menu.

12. You changed your mind? Select Delete Node from the Project or Context
menu – or hit the Delete key.

You may wish to continue reading and looking for data about the categories for which
you already created nodes.

Placing your nodes
In Tutorial 6 you will learn the ways of moving nodes around, and using tree
structures to represent their logical relations. If you wish to tidy the “starter” nodes
you’ve created, go to that tutorial for the techniques of cut, copy, merge and paste.

You may later wish to revisit the early ideas as they were represented by these
first nodes. They offer a way of recalling your early assumptions, what you thought then
would be important, what the literature alerted you to. One way is to make a Set of all
the nodes that you create at this starting-out stage of your project. But if later you
delete a node, of course its shortcut will be deleted from that set. Another way is to
store a report o your nodes at this stage, and later stages. (Go to Tutorial 6 for ways of
reporting your nodes.)
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2. Coding at an existing node

To set the screen to suit your coding
1. In the folder of Sources, select Documents and from the List View select the

document you wish to read and code. Double click to open it in the Detail
View. This window, in which you annotated and linked a document in the
previous tutorial, also offers several ways of coding.

2. Click on Nodes>Free Nodes and the List View shows your Free Nodes.

3. Now set the screen to suit you. Most researchers when coding wish to see all
their nodes displayed beside the content being coded. From the View menu,
select Detail View>Right, to see the panels of the Navigation Window
vertically.

4. The Coding toolbar offers ways of selecting nodes and buttons for coding
functions. You may wish now to move it to the bottom of the Detail View.

5. Hover over the icons, or go to the end of the toolbar to check the names for
each option. You may wish to hide some of them – but first, check what they
do! One will be wanted often: the green tick over lines of text that says Code.

Now you are ready to code at your existing node, in any of several ways. You can
drag and drop, use the menus or use that coding bar.
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To code by drag and drop at an existing node
1. Select some text that you wish to code at the Free Node you have created.

2. Drag the text onto the node. (the mouse icon shows that it is being “dragged”
and then that it has “dropped” what it was dragging.)

To code at an existing node using the menus
1. Select some more text that you wish to code at an existing node.

2. From the right mouse Context Menu or the Code menu, select Code>Code
Selection at Existing Nodes. Note the other options: to code at a new node,
the node currently showing in the coding bar, or to code at any of these whole
source(s).

3. NVivo asks what node do you wish to code at, by offering the Select Project
Items box. Select the node, or if you wish more than one node, and click OK.

4. The node selected appears in the slot for a node name in the Coding toolbar.

To code further content at this node, select it and click the Code icon.
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To code with the coding bar at an existing node
The Coding Bar can be used directly. Check if this suits your style.

1. Select some more text that you wish to code at an existing node.

2. Check what node is in the slot in the coding bar. When you click the Code
button, it will code at the node showing there.

3. To select a different node – or nodes – to code at, set the coding bar to Code
At| Name, and click the […] button to Select Nodes.

4. From the Select Project Items box select the node or any number of nodes at
which you wish to code this text.

5. Click . Note that if you change your mind, the Uncode icon is the next
on the bar!

Those prior categories will probably not suffice for what you are now seeing in the
data. Researchers sometimes start this way.

But almost always, most categories are discovered and created “up” from the data, as
they read and interpret data sources. This is the most usual form of qualitative coding.

You could of course create new nodes as you discover new categories, and continue
as above, making the nodes first, and then coding at them by dragging the text to them
or selecting them and clicking Code.

But NVivo allows you to combine these processes, making the nodes and coding at
them as a single task. As you work with your data, you’ll make a lot of nodes!

This is the next task. If you are new to qualitative coding, you may like to follow the
steps in Chapter 5 of Handling Qualitative Data.
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3. Creating new nodes “up” from the data
As you read the document, you may see a category “emerge”. You can make the
node and do the coding as one task, either with the menus or with the Coding Bar.

To create a node by coding (using the menus)
1. Highlight some text you wish to code.

2. From the Context Menu, select Code Selection at New Node

3. In the New Free Node box, type a name for this node – the category or theme
- and, if you wish, a description. Click OK.

4. The node is created and the coding done. Your new node appears in the Free
Nodes List View and in the Name slot on the Coding bar.

5. If you wish to place the new node in another node area, use Cut and Paste as
described in the next Tutorial.

The process you just conducted is often the most exciting and important one early
in a project. It’s worth becoming very familiar with this swift task, so the creation of a
node and coding of data at it feels like thinking aloud.

Note there is a shortcut – Ctrl+F3 – for coding a selection at a new node, and when the
New Free Node box appears, if you wish to place your new node in Free Nodes, you
need only type the name and press return – the rest is done for you.

Try working through some rich data, making new nodes as they occur to you, using the
shortcut, type name, press return.

To create a new node whilst coding (using the Coding Bar)
1. Highlight some text you wish to code.

2. On the Coding Bar, check that the slot is set to Name.

3. Type the name for this node. (If a name is in the slot, highlight and type over.)
Select the node area it will be in.
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4. Press Return (that’s fastest!) or click Code.

5. The node is created and the coding done.

To create an In Vivo node and code at it
You can also create the new node by naming it with the word(s) in the text you are
coding.

This is called “in vivo” coding, a technique very important to researchers who wish to
record the categories emerging from their data (see Handling Qualitative Data p.95.)
It’s useful when the data provide specially suggestive or meaningful concepts. For
example, in the Volunteering project, Anna used the term “self worth” to explain
motivation to volunteer, a new idea which you might like to store.

When you do in vivo coding, you name the new node with all the text you selected.
Make the selection brief and relevant – long node names are awkward to use.

1. Highlight a word or a few words in the text with which you would like to name
a node.

2. Click the “Code In Vivo” button on the coding bar, (or use
the Code or Context menus)

3. The node is created (in Free Nodes) and the coding done. Your new node
appears in the Free Nodes List View and in the Name slot on the Coding bar,
so you can code again at that node immediately.

4. Note that a shortcut is Ctrl+F8. Create a new node using that shortcut.
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4. Viewing your coding
There are many reasons why you may wish to see what coding you’ve done, or what
content is coded at a node – for example, to review your coding, compare with a
colleague’s coding, browse to check what else is coded in this source at that node, or
simply to get back to coding where you left off.

NVivo provides two ways to view your coding as you work. Both are on the View
toolbar (and the View menu and right mouse Context menu).

When you are in the Detail View of a source or node, Highlight and Coding Stripes
are available.

To Highlight Coding
1. In the Detail View of the document you coded, click Highlight.

(or select Highlight from the View menu).

2. Select the option you want

3. In the Select Project Items window, select the node or nodes you are
interested in. The coded text is highlighted yellow.

Why would you select Coding for All Nodes? This will show you everything
that has been coded – and thus everything you haven’t coded yet – a useful
way to see how your coding is progressing!
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The whole document may be highlighted when you select Coding for All Nodes.
Why? Probably, as in Anna’s interview, the entire content is coded at a Case node.
To exclude Case Nodes (or any other node type you don’t want), in the left pane of
the Select Project Items window, click Automatically select subfolders, and then
select all the folders whose nodes you want highlighted.

.

To use Coding Stripes
NVivo will show in the right margin of a Detail View (source or node) colored lines
that show where content is coded at up to seven nodes, and a grayscale line that shows
the Coding Density for that content.

1. In the Detail View of the document you coded, click the icon for Coding
Stripes, or select from the Project menu or Context menu.

2. Select to Show Nodes Coding Item. The Select Project Item box will
appear.

3. Select which nodes you are interested in and click OK. The stripes appear for
those nodes. If you code some more, at the nodes for which you are showing
stripes, the lines will update.

4. In Detail View, the coding stripes appear where there is coding at each
selected node. Each selected node will be marked by its specific colored line
throughout Detail View, so you can scan for coding at each.



Teach Yourself NVivo 7: tutorials by Lyn Richards 54

5. Hover over any stripe to see the node’s folder and full name.

6. Right mouse to select to Highlight Coding at that node throughout the Detail
View, to Open Node or Uncode.

Explore the options so you can use the stripes strategically. Two tips may assist:

 To use coding stripes rapidly to view current coding, select to show Nodes
Recently Coding Item.

 Show stripes for just a Selection to focus on nodes coding that passage. Most
sources or nodes will have coding from a large number of nodes, but if you
make a small selection, you will most clearly see what codes it.

To use the coding density stripe
The Coding Density stripe is shaded to indicate number of nodes coding this segment
of the source content. Hover over the stripe to see all the node names.

If you wish only to monitor what coding at any of your nodes applies to the content,
without showing the colored stripes for particular nodes, from the View menu or the
Coding Stripes icon, select Show Coding Density.

The Coding Density Stripe offers a quick way to check on the state of your coding.

You went off for coffee and need to know where your coding work had taken you in
a source? Show the Coding Density stripe and it will be obvious! (Remember that if you
coded the source entirely at a case node there will be at least one node coding past
where you had worked before coffee.) Alternative tricks: place an annotation noting
things to remember when you return to the coding – you can use a Text Search Query to
search just annotations in just one source for a word you inserted. Or simply edit into
the text where you finished coding a keyword like CODEDTOHERE and use the simple
Ctrl+F (find content) to locate it.
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5. Working with Coded Data
The primary goal of coding is usually to gather and review and work with all the
material about a topic or concept. You were coding data in order to be able to see all
that coded material together, to interpret its variety and to explore its context. Now to
the node!

You can view the coded content of a node in exactly the same way as you view a
source – in Detail View. Moreover, you can code that content, to other nodes, just as
if you were coding a source. This is called coding on.

Working in the Node Detail View
1. In the List View of any node folder, double click on a node you’ve coded at.

The coded segments appear in Detail View. Each segment has identifying
information for the Source and the number of references coded from that
source at this node.

Are you still using the online Help? Go to Help and Opening Nodes for full
detail about what is showing in the pane.

2. Click on the hyperlink above a segment to open the Source from which that
segment was coded.

3. Note that any annotations or other links that you made to this segment of the
source will appear and are live, just as they would be in the coded source. And
you can place a new link, just as you would if you were in the source from
which the extract came.
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To work with the coded content and its context
Now explore the options that allow you to see less or more of the text of every excerpt
from sources that you have coded.

1. First, adjust what you are seeing for your purposes. You may wish to reduce
the amount of text you see as a Coding Excerpt, to get a big picture. From
either the View menu or toolbar, you can select to see all or none of the coded
text, or just the first line of each excerpt

2. Now to see more of the context of each segment, to understand for example
what question the speaker was answering when she said that. From View
menu or toolbar, select Coding Context. Nominate how wide a context you
want to be shown. NVivo will shows that extra context in the Detail View in a
pale color. If you wish to improve the coded selection by coding some of this
context, select the words to be included, and click Code! This node is waiting
in the Name slot.

3. A third option allows you to spread the coding to a wider context without
first viewing the extra content. From the Coding menu or toolbar, select
Spread Coding. Again, you can select a small or very wide spread. That
wider context is coded at the node. Changed your mind? Undo!

4. Often when reflecting on a coded passage, you may wish to return to rethink
the original source. You can jump directly to the place in the source from
which the coded passage comes. Click on the hyperlink above the passage, or
from the right mouse context menu, select to Open Referenced Source.

5. Wondering what else codes this content? Show coding stripes or highlight
coding, just as you could in the Detail View of a source. Or highlight text, and
select View>Coding Stripes>Show Nodes Coding Selection. In the Select
project Items dialog, only those nodes that actually code the selected text are
available to be viewed as stripes.
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To code on from the Node
1. Read the node’s content, and consider whether there are other places to code

it. For example, are there several different motivations for volunteering coded
at that Free Node?

2. Select content and code it at a new or existing node, (the processes are just the
same as for coding a Source). In this way you can develop your ideas beyond
the original coding.

To store your ideas about a node
Continue, reading and coding your data, working with the content coded at your
nodes, expanding or revisiting context of coded passages. Create nodes as they are
indicated in the text, for topics you wish to collect data on, or concepts you wish to
explore. But remember to store your growing thoughts about that idea.

1. For each new category you create, unless its meaning is obvious, enter a
description. You can alter the description at any stage.

2. If you find you have created a particularly interesting category, you may wish
to make a Linked Memo for it. Any node can have a linked memo. Revisit the
previous tutorial for the process of making a Linked Memo.

In all this work, you are creating ideas, which need logging for your analysis. The
List View of Sources>Memos shows what Linked Memos you have made for your nodes
(sort them if you wish). Click on the Links folder and then on Memo Links to see and sort
those belonging to a source or a node.
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6. Auto-coding
Not many qualitative research processes can be automated. So it is advisable to check
which are sufficiently mechanical to be conducted automatically by the computer.
Obviously, interpretative coding is not one of these processes! But much descriptive
coding can be automated. (Tutorial 3 covered how to import attributes in tables.)

Coding of text always involves creating the node, selecting the text to be coded and
coding. All this can be automated. In this section, the exercise is for auto-coding,
using formatting of the document by headings. NVivo will make a node for each
heading and code all the content till the next heading at that node. If you plan to
autocode by heading, format the source with this in mind, ensuring that the structure
of your headings is logical. (Don’t use Heading 8 because you like the style, followed
by Heading 1!) The node tree hierarchy created will follow the Heading hierarchy
(i.e. Heading 1 will be parent, heading 2 will be a child of the previous Heading 1 and
so on. These techniques do a mechanical coding process. Check the warnings in
Handling Qualitative Data, Chapter 5 about interpreting mechanical coding.

To format for autocoding by heading
When you type your source, either in MS Word prior to importing to NVivo, or in
NVivo, create headings to name the nodes you wish to code at. Make them brief!

If you are typing in MSWord, always use the Style slot to create headings. Making

it BIG and BOLD does not make it a heading! You can see the headings in a Word
document by selecting View>Document Map. Anna’s interview looks like this in Word.

Note: two levels of Heading are used for brief names for each question and sub-
question. The full text of the question and the answer are in (different color and font)
Normal style.
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To do autocoding by heading
In this example, we will autocode all answers to each topic posed in the interviews,
creating a node for each topic and coding all the answers at it.

1. To create the nodes for each interview topic, you need to make a node below
which all the question nodes can be stored. Here is an obvious use for the Trees
area of the Node Explorer. Click on Trees, and in the List View, right mouse to
create a node. (Or use the Project menu, or click on New and select to make a
new tree node in this folder.)

2. Name the new node. It’s good practice to note in the Description that these node
trees are being made by autocoding.

3. Now go to the folder of Sources you want to autocode. (You may wish at this
stage to import some more sources if there are several with the same formatting.)
Select the items to be autocoded and select Code>Auto Code…

or click Auto Code on the Coding bar

4. In the Autocode dialog, leave the options unchanged and click Select.

5. In the Select Project Items window, click on your new Questions tree node, then
OK. Confirm the Autocode instruction with OK.

6. Now, check your Tree Nodes to see what you’ve done. The List View shows the
nodes created and named and what coding was done automatically: in the Sample
Project nine sources were coded at each topic node with one reference from each.
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When auto-coding is completed successfully, this does not mean that the results
are as you expected! Go to the node for one topic, double click to see in Detail View what
was coded at it. It should contain each person’s answer to that particular question – no
more and no less. If it doesn’t, return to check that your formatting was as you
intended.

Other ways of autocoding
Now check the options in the autocode dialog. Did you notice that if you autocode by
heading, you could specify what heading level you were autocoding? For your
project, consider how this could be used. For example, in the Sample Project,
autocoding at Heading 1 coded focus group topics. By autocoding at Heading 2, Case
nodes were made coding what was said by each focus group participant. It’s all in the
formatting!

The Autocode dialog also allows you to code by paragraph. (Go to Help for details).

You can also automate coding by text search, using the occurrence of words in the
text, and NVivo’s ability to code the context you specify.. For instructions on text
search, go to Tutorial 8.

This concludes NVivo 7 Tutorial 5. For full discussion of the purposes of qualitative
coding, either interpretatively or automatically, and uses to which these software tools
can be put, go to Chapter 5 of Handling Qualitative Data.

You now have data, ideas about your data and have started to relate them by coding to
gather the relevant data at those ideas.

Don’t forget to back up your project. The next task is to manage those growing ideas,
and this will change your project dramatically.
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NVivo 7 Tutorial 6:

Relationships and Other Nodes: Handling Ideas
The previous tutorial was about discovering or creating new ideas and the nodes that
store them in NVivo. This tutorial is about managing the relations between ideas.

NVivo provides four folders for nodes, representing four different sorts of categories
at which you may want to code data. Three have been encountered in earlier tutorials
– Free Nodes, Tree Nodes and Cases.

The first section of this tutorial is on the fourth, Relationships. It shows how you can
store relationships you see in your data, and code the evidence for those relationships.

The next sections are about managing categories. Ideas isolated are the researcher’s
enemy. And ideas that are not organized and managed are often very problematic.
You may lose them, or worse, you will lose them sometimes. The next sections are
about how to catalog ideas, by reviewing, merging and rearranging nodes and their
coding in trees. Tree organization also facilitates many query operations.

As you work in your project, you will find that coding data or exploring relations of
ideas always requires finding nodes, and seeing their associations. In order to bring
data and ideas together, and create new understandings, data management is
necessary. As in most areas of qualitative method, efficiency is necessary for
creativity.

Revisit Tutorial 5 for ways of creating, naming and describing nodes and coding at
them.

If you are setting up your own “real” project, you will be greatly assisted by early
attention to the management of your ideas. Software enables far more categories to be
created, and far more coding to be done at them, than manual methods. This is a great
advantage, unless the categories become a problem to the researcher. From the start
of your project, work with your node system, visiting and reviewing, revising and
improving it constantly. This is a major way of “talking to” your project.

The goal is to have the node system as parsimonious and efficient as possible, without
losing any insights or hunches that should be contained in it. (Rather like a shrink-
wrapped package, a useful node system is as small as it can be whilst being as big as it
needs to be!)

Go to Chapter 6 of Handling Qualitative Data for advice on cataloging the categories
that are part of the research design or emerge from the data.

To review what you need to know about creating nodes and managing them in NVivo,
go to Help.
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1. Relationships
Relationships in NVivo 7 define relations you see between sources (documents,
externals or memos), nodes (free, tree, case and query results) or sets. If two of these
items seem to you to be related, you can record this in your project, creating a
Relationship that links them.

And that Relationship is itself a node. Like any other node, it can have coding. If you
wish, you can code at the Relationship the data that you see as pertinent to it.

Relationships can be added between any sources and any nodes (except relationships)
or any sets of sources and/or nodes. Like any other node, they can have any amount of
coding, and the coded content can be browsed and recoded (see previous Tutorial).

In the Nodes folder of your project is a separate folder for Relationships. As you
make relationships they will be shown in the List View.

A relationship has a “from” and a “to” item, linked by an arrow whose “type” you
define.

In the Classifications folder is a folder for Relationship Types. You name and
describe types of relationships, and specify how they are shown - a nondirectional
“association”, or a one-way arrow or symmetrical (double headed) arrow.

Family values seem to encourage (though not directly cause) motivations to
volunteering? You need a relationship type “encourage”. And a relationship between
two project items – e.g. the memo about family values and the node for motivation.

If you don’t have nodes or sources to represent the relationship’s “to” and “from”
items, create them. NVivo has no problem with nodes or sources with no content. In the
example above, “family values” could be created as a memo, named and described in the
project. Later as you explore the relationship you may wish to write your changing ideas
about family values in the memo, then code some material at the relationship.

To make a Relationship Type
1. Go to the Classifications folder, and click on Relationship Types.

2. As for any other new item, click in the List View and then from the Project or
Context menu or the New button select to create a New Relationship Type.
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3. In the dialog, name the Relationship Type, and add a description. (This is
usually very important as you may be creating many Relationships of this type
and need to check consistency.)

4. Now select the direction of the Relationship

To make a Relationship
1. Select the Nodes folder, and in it the Relationship folder.

2. As for any other new item, click in the List View and then from the Project or
Context menu or the New button create your new item.

3. Select a “from” and a “to” item, and then the “type” for this relationship. Note
that the description of your Relationship Type appears, so you can check that
this is appropriate. Click OK.
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4. The new relationship appears in the List View. Note that as you record more
relationships, you can sort them in List View according to each column – for
example, get all the relationships of type “decreases” listed together.

5. Each Relationship is a node, and you can select it, just like any node, to code
at it any source content that you see as pertinent to this relationship.

Using Relationships in your project
Relationships that can code the relevant data are an entirely new tool with NVivo 7.
They may be used for very specific statements of fact (Anna lives with Sunil) or very
abstract reflections (lack of time decreases motivation to volunteer),

For your project, ask early what relationships you are anticipating, then as you work
with the data, create and code at Relationships that express what you are discovering.

If you create two or more different sorts of relationships, note that while they
cannot be in subfolders, they can, like any nodes, be managed in Sets. Here the
researcher has created different sets because some relationships record conceptual
relations, and others simply domestic relations like living together.
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2. Reviewing your nodes
If you have been coding data, you may already have begun assessing the nodes you
have made, and rather than placing them all in Free Nodes, sorting them into “Trees”.

As explained in Chapter 6 of Handling Qualitative Data, tree structures allow you to
catalog nodes so they are easily found and consistently used.

NVivo does not require that you keep any nodes in Trees, but you will be greatly
assisted by doing so. Cataloguing nodes does not require “top down” thinking. Rather,
as you see that some of the free nodes created are all a “sort of” a more general
category, you may create that category and move the nodes under that “parent”.

To do a review of nodes
1. On a whiteboard or very large sheet of paper, or in a model in NVivo, review the

nodes created so far. Do you see the categories needed for thinking about your
project there? If not, sketch in the other categories you think you will need.

2. Now in your NVivo project, open Nodes>Free Nodes. In the List View review
the free nodes created so far. Click on relevant columns to sort them – e.g.
according to amount of coding, or date of modification.

 Are they named accurately and described adequately? Go to a node’s
Properties to change any name or description.

 Are there more categories needed to ask the questions or explore the issues
you are tackling? If so, create the nodes.

3. Do they belong together in any logical order? Don’t force it! In NVivo (in a memo
or a model) or if you prefer, on paper or whiteboard, sketch the shape of a starter
catalog that looks logically sensible. If a category doesn’t belong with others,
leave it free.

 Looking “top down”, from your project design; what are the main areas of
enquiry? Revisit the categories you started the project with

 Now consider the categories you created from the data. Do they hang together
in logical groups? Ask each, what is it a “sort of”. If some nodes group
logically, note this. (For detailed advice on cataloging nodes and evaluating
the node systems you create, go to Chapter 6 of Handling Qualitative Data).

Consider carefully how the growing node system relates to your design or
intentions for this project. A good rule of thumb is that if you want to ask questions
about your data in NVivo, you will need nodes in terms of which the questions can be
stated. If you have done a project design, or a literature review, try importing that into
NVivo and coding it: the project needs the nodes that result.
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3. Rearranging nodes
At this stage, you may make major changes to your project. You did back it up at the
end of the last tutorial, didn’t you?

You can cut or copy, and paste or merge, any node in NVivo, without losing any of
the data it codes, or its links to a memo or, if it’s a case, its attributes. So if your nodes
now should be catalogued, the steps are simple.

To cut and paste a node
1. Back in your NVivo project, create nodes in the Trees area for the main categories

you have sorted your ideas into. These new tree nodes will be “parents” for the
subcategory “children” that belong there. (The child nodes are a “sort of” the
parent.) Thus my node for “self worth” might go with other categories about
perceived benefits under the parent node, “benefits of volunteering”). Create any
parent nodes indicated by your review.

2. Go to the Free Nodes you created by coding in the previous tutorial. Select one
that properly “fits” as a “sort of” one of your new parent nodes.

3. Right mouse click and Cut the node from the Free Nodes area

(or use the Cut button).

4. Go to the parent tree node you want to place the cut node under. Right mouse and
select to Paste the node. Click the “+” at the parent node, and you will see your
pasted node, which still holds all the coding you had done.

If you prefer caution, Copy, and then when you’re sure it’s pasted correctly,
Delete the free node.)
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To shape your node system
1. Continue cutting and pasting nodes as indicated by your review, until you are

confident the arrangement is logical and that it does not in any way force your
thinking about the categories or pre-empt things you might later find. (Chapter 6
of Handling Qualitative Data advises on design of tree catalogs avoiding these
traps.) Remember, if a node won’t logically “fit” in a tree, leave it in Free Nodes.

2. Now code another document, working with the categories as they are now
arranged, so you can find existing ones and place new ones. You will find that as
you work with the nodes, now, it is very easy to cut or copy and paste or merge as
the system of nodes starts making sense.

3. Visit the categories you have left “free” of the catalog and review them.

A good habit is to review nodes left “free” often – as the catalog forms, the
remaining Free Nodes are special. They are the categories that don’t fit anywhere.
Maybe they are just irrelevant? But maybe they are the still unconnected ideas that will
become crucial in making sense of the more organized thinking about your project.

To merge nodes
Often at this stage of a project you find that you have more than one node for the
same idea or concept. This is quite common, not to be regarded as a problem. Indeed
it’s good practice to keep nodes separate if there’s a chance that the meanings are
subtly different, and bring them together only when you get surer of their common
ground. At that stage, you need to be able to merge their coding – and any other
contents or links of the node.

1. Select a node you want to merge into another. Cut or Copy it (depending on
your purposes).

2. Now select the node you want to merge this coding into.

3. From the right mouse context menu, select to Merge into Selected Node.

4. select what you wish to merge, from options presented.
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5. Click OK. The nodes are merged.

Evaluating your node system
As the nodes are moved and merged, you will find a stronger sense of how they relate
to each other. Treat the tree catalog like the catalog in the library, which assists you to
look for an item rapidly, check if it’s there, browse the items near it and note what’s
missing.

Like any catalog, it is only as useful as it is logical. You will find that revisiting your
node system is richly rewarded with increased efficiency and a stronger picture of
how the project is shaping.

Regularly, make time to check for and remove or merge duplicated nodes, examine
and delete nodes that have proved unnecessary or redundant, and ensure that the
logical structure of the node system remains strong and clear to you.

The catalog of nodes will change, as your understanding of what’s going on in these
data grows. So the node system at any time will be a record of where you are “at” in the
project. A highly useful technique for logging progress is to save and archive a list of
your nodes at regular intervals, or at significant milestones in the project.

For advice on constructing a tree structure that will work for your project, and for
ways of checking it remains logical and useful, go to Chapter 6 of Handling Qualitative
Data.
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4. Listing and Reporting on Nodes
Now to get a report on the node catalog you have created. You can print the nodes
that are displayed in List View. This is a what-you-see-is-what-you-get printout, so
you will need to expand the hierarchies that you want to include. Alternatively, you
can make a very detailed report on all or some of your nodes.

To print the list view:

1. In Navigation View , click the Nodes button.
2. Select the folder containing the nodes you want to print. To print a list of all

nodes, select the All Nodes folder under the Search Nodes folder.
3. On the File menu, click Print List.

To make a report on your nodes

There is a range of reports available with detail and formal layout, from the Tools
menu. The Node Summary report will give you everything you could want to know
about each of your nodes and its coding.

1. On the Tools menu, select Reports>Node Summary Report.
2. In the Customize Node Summary Report window, select the nodes you want to

report on, and specify your requirements. Note: hierarchical name will give you
the tree structure if you have nodes in trees.

6. Click OK. The report appears on the screen.

Read the report, and if it is useful, print it.

Note that the report (like all reports generated this way) is not immediately
editable. If you wish to save it as an editable report, from the toolbar, choose to Export
the report.
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To log your development of nodes
1. Write a memo about this first stage of catalog construction.

2. If you are working in a team, and wish to merge your projects later, this is a good
time to design a common catalog of basic categories and discuss how you will use
it to ensure consistency but allow innovation. If you are planning on merging
projects by Project Import, please go to the Online Help for advice.

To create a coding comparison report
Amongst many other reports of your nodes and coding, you can make a special report
on the similarities and differences in coding between two sources.

This report can be used for exploring different coding styles or checking differences
in coding by different team members, as well as comparing coding across time as
your ideas develop.

1. From the Tools menu select Reports>Coding Comparison.

2. In the Customize Coding Comparison Report dialog box, select the required
options to specify the two sources whose coding you are comparing and the nodes
for which it will be compared. You can also specify what information on the node
content you want. Go to Help for details.

3. Click OK.

Do be careful to interpret the results appropriately: coding reliability is a
challenging goal in qualitative research, and claims to reliability must be carefully
established and discussed (see Handling Qualitative Data pp 98-100.)

This concludes the NVivo 7 Tutorial 6. Go to Chapter 6 of Handling Qualitative
Data for advice on these processes.

You now have not only data and, ideas about your data, but also an evolving
management system for those ideas. Time to back up your project!

As you continue relating data and ideas via links and coding, the ideas will be
accessible for review and reflection.

If the reorganization of your nodes is satisfactory, you will now be able to “see” the
relationships you are discovering and the logical groups of concepts and categories
that are emerging in the project via the catalogs of nodes. But the catalog does not
show the theories you are growing about how these categories relate. The next task is
to represent the project visually in a model.
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NVivo 7 Tutorial 7:

Models
The next stage for most projects is revisiting the project’s purpose, goal and intended
outcome, considering possible and useful outcomes for your project and seeing the
ways to get there. For these tasks, you need many of the skills in the tutorials so far –
memos, coding reviews and work on the node catalog.

But almost certainly you also need the ability to draw and show models of what is
going on, and what is aimed for. This tutorial shows how to create models indicating
the possible outcomes and how they would work for your project.

There is a much wider discussion of ways of seeing and considering project outcomes
in Chapter 7 of Handling Qualitative Data.
For full instructions about making and shaping models, go to the online Help.

Creating your model
Revisit Tutorial 4 to customize the Model window.

To create a model and work in it
1. Select the Models folder and choose your first model. (If you completed

Tutorial 4, you created a first model. If there is no model in your project, revisit
Tutorial 4 and make a new model.)

2. Importantly, don’t assume this first model has to be a definitive representation
of anything! It’s a first effort at picturing where you are. Place in it the items
relevant to your work. A useful first step is to reflect on the differences between
the assumptions you took into the project, those informing the literature, and
what you have learned when you entered the research field.
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1. Using the model to show the project
You can add any source, node, attribute, value, set or model. Note the Select Project
Items box shows the items already in your model as grayed out.

If appropriate, place links by selecting two items to be linked, (Ctrl + Click + Click)
then from the right mouse context menu select New Connector.

As shown in Tutorial 4, the items you put in a model are live – you can open any item
from the model.

You can also add associated data. What documents are coded at this relationship, for
example? Experiment with the effects of asking this for different nodes and watching
the ways the patterns of coding are pictured. In this simple example, I have asked
which documents are coded at the relationship “lack of time decreases motivation”?

Adding associated items
1. In your model, from the Context menu select Add Project Items.

2. In the Select Project Items window, select the node (here, a relationship) of
interest to you.

3. From the Add Associated Data window, click Sources Coded.

4. The associated data items requested will appear in the model, and you can move
them to show clearly the associations. Here, it is used to see which documents are
coded at the relationship “lack of time decreases motivation”.
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5. Now use the modeler to clarify a pattern. Add to your model the nodes which code
contrasting ideas – here, the positive and neutral or negative images of volunteers.
Use color to display the contrast (select line or fill color from the edit menu).

6. By adding items coded by these nodes, I explore how these images are patterned
across interviews with females (mauve fill) and males (blue).

7. To see more of your model with items and text smaller, go to the View menu and
select Zoom.

Beware of selecting to add associated items if there will be very many of them.
This will not assist you to see the pattern clearly. If your model is suddenly
overwhelmed by associated items, remember Undo!

Better, use the Find tool (see Tutorial 8) to find the relevant associated items and then
drag to the model from the List View those you want to see.
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2. Designing the model
Appearances do matter (sometimes)! Model appearance is important, and not merely
for aesthetic reasons. If your model is to show ideas, and suggest missing links, you
need it to present clearly the ideas you are expressing.

You can change the appearance of fonts, lines and the fill of shapes. These and other
aspects of the appearance can be set as a model style. And NVivo provides four auto
layout options for arranging items.

To alter color and font
1. In the usual Edit bar, you can set color and font. The edit bar will also allow you

to select a color for the fill of a shape.

2. From the Format menu, you can select font, line, fill or model style. (Note that
one Fill option is an image – but beware of inserting very large images in your
model!)

To set a model style
You can set a model style for only the current project from Project Properties.

To set a style for all your projects in future , first close your project.

1. In the Welcome window, select Tools>Options.

2. Click the Model Styles tab.

 To edit an existing style (including the default style), select it and set the required
options.

 To add a new style click New Style, and choose the options you want.

1. Click OK.
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To set and change your Model’s Layout
1. Click in the model.

2. On the Model menu, or the context menu, click Layout. The Model Layout
dialog box is displayed. Select from the four options. Note you can also set
how long is the minimum length for connector lines.

4. Click OK.

To set a default model layout for all new projects
1. In the Welcome Window, before you open a project, select Tools>Options.

2. In the Application Options window click the Display tab and Model
Layout.

3. Select the default model layout you prefer. For example, if you work mainly
with trees of nodes, the hierarchical layout would be the best default.
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3. Hiding and showing groups in a model
You can make a model that is accessible in groups, so can be shown layer by layer, to
tell the story of your interpretations of the data, or to compare different views.

To do this, you nominate which of the items in the model belong to which group. A
shape or connector can belong in multiple groups. You can show and hide groups.

If you have worked previously in NVivo 2, you probably created layers and groups,
viewing them through the Palettes. NVivo 7 simplifies this process by allowing you to
create groups and show or hide them to see them as layers.

You can create custom groups for the shapes and connectors in a model. For example,
a team might create groups for the different members’ concepts. Use groups to show
the stages in development of a theory. Show or hide the groups to tell that story.

To create custom groups
1. On the Model menu, click Group> New Group.

2. In the Model Group Properties dialog enter a name and if you wish a
description and click OK.

3. The group is created and displayed in the Custom Groups tab.

4. In your model, select the shapes and/or connectors you want to include in the
group. To select multiple items, click and drag or hold down the CTRL key.

5. In the Custom Groups tab, click the left hand checkbox for the required
group (under the tick).

All selected items are now members of the group.

To show and hide custom groups

1. To show or hide a group of items or connectors, clear the checkbox on the
right hand side of this group’s name (under the icon with an eye).
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2. Experiment with groups as ways of layering your model. Showing and
hiding Groups is a useful process early in a project, when it’s hard to see
the big picture. For example, in the Sample Project, as a first sorting step,
you might group the nodes for “images” into “positive” and “negative”.
Now if you show only positive, you may discover that some of the more
interesting images have left the model. Perhaps few of those images are
clearly just positive or negative?

As you work with models, carefully distinguish between the purposes of node
cataloging (in trees) and modeling. A catalog shows how, logically, your categories
are related. In a model you show how, in the project data, or your hunches and
predications about that data, or the theory you are creating, those categories may
relate.

Computer projection of such a model to an audience is an impressive presentation
format for qualitative research. Each stage can be shown and discussed, since the
items are “live” to the data, you can show your audience the detail of the data. The
last tasks for this tutorial are about ways of saving and showing your models.
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4. Saving and presenting your model
Models can be saved in the project either as dynamic models (linked to the data) or as
static models (no longer linked, so they remain a record of an early stage of your
analysis. These have very different uses.

A dynamic model can be opened and developed further at any stage, and the data
items it contains can be visited and reviewed. A static model is fixed – the items are
no longer “live” to the data, they cannot be moved around or altered and no new items
or connections can be added.

So you need your model to be dynamic whilst it is growing and being actively
developed. But you may well wish to keep a static copy as part of your log of the
project’s progress.

To save a static model
1. To create your model as a static model, to store for your project log, click in the

model and from the right mouse context menu select Create as Static Model.

2. In the New Model dialog, name the model and add a description. Take care with
the name and description – they must accurately identify that model when you
return to it. It is good practice to include “static” in the name, so you will not get
confused about which models are still “alive”.

3. The static model is created (with a different icon).

A useful strategy is to create two subfolders in your models folder for dynamic
and static models, and move this newly saved model to the folder for static models. Note
the icons for static models are different from icons for dynamic models.
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To copy your model into a paper or presentation
You can copy all or any parts of a model and paste into a paper in your word
processor or a presentation. To copy the whole model

1. In the model, select all (Ctrl+A) and copy (Ctrl+C).

2. In your word processor or presentation software, paste (Ctrl +V).

3. The model pastes into your paper or presentation and you can resize or add
text.

Using models to communicate your project
As an exercise, present the modeled story of your project so far to colleagues.

1. Using show and hide, diagram some aspect of the evolving story of your
project. It could be as simple as a rearrangement of a tree of nodes, exploring
whether there are clusters of different meanings.

2. Use groups to identify clusters. Place items and connectors representing the
“story” or map of early research thoughts.

3. In a presentation to colleagues, use this grouped model to explain how your
project is going, jumping from the model to the project item to show the data
and discuss the possibilities and limitations of your work.

This concludes Tutorial 7. For advice on the early stages of “seeing” your project and
planning the required outcome, go to Chapter 7 of Handling Qualitative Data.

You now have data, linked to other material and to ideas via coding. You have
organized nodes in catalogs and modeled the beginnings of notions about how they
relate in the data. You can of course delete or alter the models, but it’s highly
advisable to leave them as an honest record of where you were. They will become part
of your log trail.

The next task is to use the ability to search your documents and ask questions about
your coding in order to develop those growing ideas.
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NVivo 7 Tutorial 8:

Asking questions
This tutorial covers a range of techniques for finding and querying your project items
and content – and using or saving the results. You may wish to work through it in two
parts – first Find, then Query. But they are presented together here to help you see
their differences and the ways they complement each other. Any Find or Query in
NVivo 7 is a way of shaping or coding data. The result of a Find or Query can be
saved as a set or a node. But they are ways of asking different questions.

Chapter 8 of Handling Qualitative Data is about the ways of searching text and coding,
how different these are from manual methods and cautions in interpreting them.

To review what you need to know about Find and Query, go to the online Help.

Find and Query – what’s the difference?
The Find tool is for simple or advanced questions about your project items. Use it for
locating lost items, asking what you have in your project, checking sample
characteristics.

The Query tool is for simple or advanced questions about the content of those items.

Three differences matter.

1. Find and Query answer different sorts of questions:

Find will locate any project item in specified folders. Advanced Find looks
for project items with specified features. Grouped Find returns items grouped as you
request, by project item.

Queries look for source content with specified features, such as words in the
text, coding or attributes of a case. And you can build up questions using a range of
logical and location operators.

2. Find and Query offer different sorts of answers:

Both Find and Query list what is retrieved, and give the option to save those
items as a set or a node.

Find gives you only a list of project items as answer. (For Grouped Find, it
will be a sorted list.)

Queries find the actual content requested. Results can be previewed and then
optionally saved at a node. Then content can be coded, or items saved, for further
querying.

3. Queries can be saved as project items

You can optionally add a Query to your project: it is saved in the Queries
folder. These queries can be used as a record of your work. They can be altered and
rerun through other parts of the project data or later data stages.
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1. Finding items
By now you have probably noticed that (like MS Outlook) NVivo has a Find bar at
the top of your List View window. If so, you have probably used it – this is a very
simple way of finding any project item or items. For example, you have a document
and a case node for Mary – or was it Maria…? – and did you make a memo…?

To find a project item
1. Enter the item name (or any part of the name) in the Look for field. You can

include the * and wildcards (see online Help for information on these).

2. From the Search In drop-down list, select the folder(s) you want to search.

3. Click Find Now . The items that fitted your request appear in the List View .

Using the results of a Find
1. As in any List View, you can select any item to see content in Detail View.

2. If you wish to keep these finds, one way is to make a set of them. Select some
or all items. From the Context Menu, select Create As>Create as Set.

3. In the New Set dialog, name the set. You now have made a Set that contains
e.g. everything with Mary’s name in it. (Note the Summary report was
excluded from the set!) Now you will be able to focus on just those items in
future analysis.)

Using Advanced Find
1. In the Find tool click on Options at the far right side. (“Options” are the best

kept secret of Find toolbars!)

2. Select Advanced Find.
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3. On the Intermediate tab, select the items you wish to Look for (this will set
the characteristics you can ask about). For example, if you wish to find all
cases where age group is over 60, Look for Cases, and click Cases where and
select the attribute and value.

4. Add any other specification that will get what you want. For example, I don’t
want Case nodes if there is no content coded yet for that case. So here I have
also specified “That code Any Item”.)

Use Advanced options to save work later. Advanced Find is also a way of asking
questions of your sample (for example, let’s check if we have anyone aged 60+ ). Or use
it for project management: (which documents are not yet coded at any node?)
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And now, really Advanced!
The second tab on the Advanced Find box is – yes – Advanced! Don’t be put off:
this window allows you to build up plain language requirements for just what you
want. It can be as simple as a “this but not that” request: were there any documents
whose name contained Mary other than those about Mary Smith?

1. Select the items you wish to Look for.

2. In the bottom panel, Define more criteria by choosing interactions of those
items with others. For each, click Add to List. Note the range of criteria you
can specify.

3. Click Find Now . The items that fitted your requests – only items that fit all
your requests – will appear in the List View. Read or save them as a set or a
node as before.

If you have used NVivo or N6 previously, you will recognize this as a (much easier)
way of doing one form of a task previously done through the Search Tool: Boolean
intersection. You have found all and only the with characteristics you specify. But if you
want to know about the content of those documents, you need another tool.

And now for Query!
The next step is to explore Query.
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2. Text Search Query
Any query in NVivo has a format that will become familiar.

In three steps, you work through three tabs, (see the three areas above) to:

1. specify the criteria for your search
2. select from the options for results
3. (optionally) Add the query to your project for reuse.
And then, if you wish, you can run the query.

Here, we start with a Text Search Query.

To set Text Search Query Criteria
1. In the Navigation window, click on Queries. That folder contains folders for

Queries and Results. You can make your own sub-folders for different sorts
of Queries (but not for Results). Create a sub-folder for Text search queries.

2. Click on the folder you want to place a query in, and click in the List View.
Using any of the ways to make a new item (Project or Context menu or New
button) create a new Text Search query.

3. The Text Search Query window opens. Type in what you want to Search
For. (Here I am searching for the words “passion” or “commit” and any words
with the same stem e.g. “passionate” and “committed”.
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4. Set the scope for this search, i.e. what you will Search in. Select text or
annotations or both, and then Of which folders or items. (See section 6.
Scoping a Query below.)

To set how the query results will appear and be used
1. Click on the Query Options tab, to specify how you get the results.

2. First, ask yourself, what do you want to do with the Results? The options are
to:

 preview results (they’ll appear in a list of items with finds);
 save the finds by coding them, either at a new node or an existing one;
 add the items with finds either to a new set or to an existing set;
 create a new node hierarchy of nodes coding the results – that is a tree, with a

node for each source in which finds occurred.

This step deserves your careful attention. As you learn the Query process,
experiment with the uses of the different options. The ability to preview only gives you
a fast way of finding whether there are any finds, or which sources they are coming
from. Remember you can always save the listed items as a set.
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3. Now, do you want to Spread Coding of your finds, to see more content
around each find? And if so, what context do you want included?

Note, you can spread to see content later – so long as you have saved the
results as a node – and this may be preferable since it will show finds and
context in different color font. (See below on using the results.)

4. And finally, don’t overlook the two tick boxes below the Spread Coding
options.

Do you want to open the results in the Detail View, to work with the content
immediately? And do you want a results node created even if no finds were
made?

To save the query
Before you run the query, ask do you wish to save it? This will allow you to rerun it
through later data or alter it to be more relevant.

1. Click the top left corner box Add to Project.

2. The General tab appears so you can name and give a description to your
query. (Use the description to record what it was designed to do, in case you
forget.)

Whilst you are learning the tool, it’s a neat idea to use the option to Add to
Project so if you find you didn’t ask for quite what you wanted you can very quickly go
back and change the specification.

Note that from the list view of results you can also return to last run query (that’s an
option on the context menu.) But if you add queries to the project often, regular
housekeeping is useful!

To run the query
1. Click Run!

2. The results will appear as you specified. Results show in the Detail View
Always go to the results to check that the query did what you meant it to do.
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3. Using the results of any query

Using Preview
When you run any query, the first question may be: did you get any results and if so,
what? Preview answers this question, and allows you to explore what you did get.

1. The List View lists the items which contained finds.

2. Click on any item to see it in the Detail View with the passage(s) found
highlighted.

Saving the results as coding at nodes
The two options to save as a new node or merge with an existing node both code the
results. All content that satisfies your specifications will be coded at a node you
specify. As with any other node, its content can be read in Detail View, the context of
coded excerpts can be expanded, you can jump to the source or code on to other
nodes.

(For example you might discover that there are two meanings of “commitment” in
these accounts of volunteering – and all these finds refer to how committed people’s
time is in other activities! Code on to a node for “too little time”?)

Using text search for automating coding
The ability to code the results of your search has very considerable implications for
your data management. Consider using text search for accessing material to code if it
is reliably indicated by the presence of a word or words you can accurately identify
with this text search query tool.

1. Create a Text Search query as above. Specify the word or words as accurately
as possible, using wildcards, stemmed search to ensure that you minimize
false finds.

2. In Options, specify to Create Results as New Node (or if appropriate, add to
an existing node). Specify the Spread of finds that will be useful for your
purposes.

3. Click Run. The node is created and opened in Detail View.

A node in a Results area cannot be altered. If you wish to alter a Results
node, and keep working with it, move it into the Free or Trees area. But you can code
on from a Results node to another Free or Tree node – this doesn’t alter the results
node. If you want to work with query results, this is often the best method.



Teach Yourself NVivo 7: tutorials by Lyn Richards 88

To see and code context of your finds
Text searches always require context, but often you don’t want the context to hide
where the actual “hit” was. To examine the “hits” in context, and separately code the
appropriate surrounding text:

1. Select at Options to Preview Only results but don’t Spread finds.

2. From the List View of Results Preview, visit each find in the source to see
content. Select the appropriate wider content, and code it at the Free or Tree
node you are creating for the outcomes of your search.

OR

1. Select at Options to save results as a new Results node and don’t Spread the
finds;

2. Open the Results node, Select All the content (Ctrl+A), and from the right
mouse Context menu or the toolbar icon, choose to Coding Context and the
amount of context you want to see.

The required context will appear in the Detail View, in pale text, so the
original find (which is all that is currently coded) is easily identified.

3. Read each passage, select just the context you want to code – and code on to a
new Free or Tree node that will contain only the finds and context you
consider relevant for your purposes.
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Help with text search
Are you a user who refuses to use online Help?

This is one area of NVivo where you must seek Help, as the NVivo search engine,
like web-based search engines, allows you to do far more subtle searching than
merely look for a word or words. Go to Using Special Characters and Operators
for many ways of making your searches powerful.

You can short-cut coding considerably by building up a node coding all likely words,
with context, and then working from it, deleting false finds and coding on to more
finely defined nodes.

Always be careful to use and interpret this rapid coding appropriately: go to
Handling Qualitative Data pp 155-8 for advice and warnings on using mechanical text
search processes for coding.
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4. Coding Query and Compound Query
Now to try asking questions about your coding. You will find the steps very like those
for text search.

There are three further query types available. (As above, it’s recommended to make
folders for the different types.) Here we start simple.

Matrix coding queries are the topic for the next tutorial. In your own time, play with
Compound queries – they combine Text Search and Coding queries.

To make a simple coding query
The Simple tab on the Coding Query window allows you to ask for everything coded
at a node or everything coded at a case with a particular attribute value.

Why do this through a Query? Because just as for Text Search, you can scope the
query to just the items you want to ask about.

1. Select New Query>Coding. The Coding Query dialog opens. Note that its
tabs are very similar to those for Text Search queries.
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2. Now click Coding Criteria, and specify the simple search. You can search for
either content coded by a node or (as below) Any case where a specified
attribute has a specified value.

3. In what data? Set the scope, just as for Text Search, by choosing to search All
sources or just the items (which can be sets) or folders you want to focus on.

4. Just as for Text Search, click Query Options to specify whether you get a
Preview Only or save as coding at nodes or save items in sets

5. Now decide whether you wish to Spread the finds to a wider context. (Revisit
Using the results of your search for revision on Query Options.)

6. In the Coding Query window, just as for Text Search, you can specify if you
want to keep this Query. To do so, click Add to Project. The General tab
opens: name the Query.

7. Click Run. And check what happened.

To make an advanced coding query
Now to the more subtle ways of questioning your data.

1. Make a new Query as before, click Add to Project and name the query.

2. Click Coding Criteria, and click the Advanced tab.

3. As with Advanced Find, build up requirements for what content is coded by.
Specify the requirement, select the project item, and click Add to List.



Teach Yourself NVivo 7: tutorials by Lyn Richards 92

Note that in coding query you can combine requirements about coding at nodes AND
requirements about the values of attributes of cases – for both, you specify that
content must have the required coding. Think through the question you are asking,
such as: I want everything about motivation if speaker is in their 20s – that is, if the
content is coded at motivation and at any case node where Age group=20-29.

4. When you have added the required specifications for your query, check that
the scope is as you wish. The default is In All Sources. Narrow the search by
selecting items, or sets or folders.

5. Click the Query Options tab to specify, as before, how the results will be
delivered – preview only or coding at a node or nodes or saving in a set.

6. Click Run.

To build an advanced coding query
Return to that Coding Query and build more requirements into it.

Note that as you specify conditions and Add to List, you can move conditions up or
down, and use the sideways arrows to bracket conditions that you wish to operate
together.

As your project progresses, you will return to the Query Tool for very many different
purposes. This is where you find occurrences of words, check who is using them, look
for patterns in your coding, test hunches and seek new ideas.

Interpreting your coding query
NVivo can conduct searches of your coding that would not be possible by manual
methods. These are very powerful, but must be properly interpreted. Note that you
can’t claim from the search above that you now know everything that motivates
women in under 40. The node codes only what you saw and coded in those
documents. You are the weak link in any such search!

I know this is sounding repetitious, but please, be careful! It is essential to
interpret these mechanical searches and use their results with great care. Check the
warnings in Handling Qualitative Data Chapter 8.
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5. Scoping a query
An important feature of the Query Tool is that you can always ask where you would
like this search to “go” – what data records do you want to focus on? Using the ability
to scope is critical for qualitative research, so it’s worth taking time to learn the tool.
Query without scope is a blunt instrument.

You can set the scope for any query to any item(s) or any folder – or to any existing
set of documents and/or nodes. In two searches, scoped differently, you might
compare two parts of your project. (If you have different folders for interviews and
focus groups, run a search through documents in each. Now you can see if the issues
were discussed differently in the focus groups.)

For text search query you can also scope the search to text and or annotations. (This
option is not in coding queries, since annotations can’t be coded.)

To narrow the scope of a query
1. Return to the Query Tool, and Text Search Query. Open the query you saved

earlier.

2. Check the Query Options tab: if you left the defaults, you asked to Search In
Text Of All Sources.

3. Select to Search In Text and Annotations. You have broadened the scope of
your query to look for the words specified in annotations as well as main text.

4. Now to get Text and Annotations “Of” just some particular data. In the
dropdown list, select Selected Items.

5. In the Select Project Items box, select a set (e.g. your set of sources and
nodes containing the name Mary).

6. Run the query again and check the results. You have found all occurrences of
that text in any project items whose name contained “Mary”.

Using Sets in Query work
The scoping of query processes is a very important role for Sets. Particularly if you
are doing a series of searches for text or queries about your coding across part of your
data, you will be assisted by making a set of the items to be searched. The set can be
selected immediately from the Query Tool.

Note, sets can be the input or output of a query.

 You can scope your text search or coding query to a set;
 You can save any or all of the items in any list view to a set.
 Results of any Find or Query can be saved as a set. This means you

can scope a new search to what you found in the previous search.
Remember, Sets can contain sources and/or nodes (which code parts of sources.)
Simply create a set to identify the records you want to search.
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6. Using Query for your project
No tutorial can lead you to the searches you need for your own project. Now that you
know the basic tools for searching text or coding, you need to set out in plain
language the searches you would like to do at this stage in your project.

For advice on framing and conducting searches in plain language, and logging what
they find, see Chapter 8 of Handling Qualitative Data.

As a final exercise for this tutorial:

1. Make a table whose first column is of plain language questions to ask using
Find or Query.

2. In a second column, record the Find or Query to be used. Use the online Help
to locate the operators that will get at the answer to your questions.

3. In a third column, record the scope to be set for the search.

4. Run these searches, and record in a fourth column what you learned.

Of course you must back up your project, but this time, before you do so, tidy it
up. You probably have many search results nodes from playing with the Query Tool.

Remember that Results nodes cannot be altered, so the only reason for keeping them is
to return to examine the result of that query, or compare with a subsequent query. If
you don’t expect to need them, write in a memo about what you learned and delete these
records of searches you don’t need to keep. If any results nodes are to be kept and
developed, by adding more coding, they must be moved into the Trees or Free areas.
Move them (using cut and paste, as in Tutorial 6,) and rename them sensibly. Add a
description to record how each was made – it’s all part of your project’s log trail.

This concludes Tutorial 8. For considerations of using these specialist tools, and
interpreting them, go to Chapter 8 of Handling Qualitative Data.

You now have data, linked to other material and to ideas via coding, and know how to
make catalogs of nodes and models to show logical and theoretical relations, and how
to search the records and their coding.

The next task is to use the ability to search your documents and your coding for
different purposes, to show and interrogate patterns. So the next tutorial is about
matrices.
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NVivo 7 Tutorial 9:

Exploring Patterns in Matrices
As a qualitative project develops, researchers need a range of ways of seeing the “big
picture”, an overall “story” or a pattern. Many of the software techniques in earlier
tutorials will be used at this stage, and your writing in memos will be all important.
But one search technique is often critical for seeing or exploring synthesis or patterns.

This tutorial teaches just that one technique – making qualitative matrix displays –
and how to use them in your project.

For a wider discussion of the challenges of seeing the “big picture” of your project,
either in an overall “story” or a pattern, and for discussion of matrices in the
qualitative literature, go to Chapter 9 of Handling Qualitative Data.

To review the uses of matrix queries, go to the online Help.

The idea of a qualitative matrix.
Tables are a very familiar way of showing the relation of one lot of features to
another. In your project, you may be looking for a pattern of how people’s ideas vary
by a demographic characteristic, for example, or how one group of nodes pattern
“onto” another, as represented by your coding.

Start this tutorial by asking which of the “seeing” processes you are exploring in your
project could be assisted by matrix display. Write the question in plain language first.

My question here, (in this highly inadequate early stage in my project) might be:
“does education pattern the images of volunteers?” I’ve an attribute for education
and all cases have values allocated (return to Tutorial 3 if you need to revise
attributes.) And there are nodes for the images of volunteers.

Matrices in NVivo
Matrix coding queries create tables to compare multiple pairs of items you specify, in
ways that you specify. Like any other Query (see previous tutorial) a Matrix coding
query can be restricted to a scope you specify. And like any other query, it can be
saved.

It’s called a matrix coding query because matrices are made of nodes that code data.
The items you specify for rows or columns are nodes, and the cells of the table will
contain data coded at the combination of those nodes you specify. For example if you
ask for the AND operator, the cells will contain content coded at cases with this
education value AND this image node.

Columns or rows can be coding categories of any sort – free or tree nodes that
represent concepts, or relationships – or cases, chosen for their attribute values. I wish
to compare images (nodes) by education (an attribute) I specify the nodes for images,
and the nodes for cases that have the required values of the attribute.

And the result, the table, is also nodes. A new node is created for each cell in the
matrix. You can open the node and explore all the material gathered there.
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1. Making a matrix
1. In Navigation View , click on Queries. Click in the List View

2. Use the New button, or from the Project menu, Context menu, select to make
a New Query.> Matrix Coding.

The Matrix Coding Query dialog box is displayed with the Matrix Coding
Criteria tab in focus. This dialog is different from those in the previous tutorial
because a matrix has rows and columns – and a relation between them.
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To set Rows and Columns
In the tabs for Rows and Columns, you specify the items to display as headers in
your matrix.

In the Matrix tab, you will specify how these are to be related. Click through the tabs
to get familiar with this process.

1. In the Rows tab, you will define the items to be displayed as row headers, and
click Add to List.

2. In the Columns tab, you will define the items to be displayed as column
headers, and click Add to List.

(See below for advice on selecting the nodes for rows and columns.)

3. In the Matrix tab, you will specify the relationship between rows and
columns.

Finally, as in every query, you can set a scope. Select to search In all Sources or just
selected items or folders.

4. As for other queries, to save it, you can click the Add to Project box and the
General tab will appear for you to name the query and add a Description.

5. Then to run the matrix, you click the Run button. The matrix will be displayed
in Detail View.

Now that you know the steps to a matrix, here’s how to specify what will appear in
the rows and column headers.

To specify attribute values
You can choose from two ways:

1. In the Matrix Coding Criteria window, for either rows or columns, choose
Selected Items from the dropdown list and click Attributes in the Select
Project Items window.

2. Click the box beside the attribute whose values you want as rows or columns.
All values of that attribute are selected. Unclick any you don’t want.
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3. Click OK.

4. Back in the Matrix Coding Criteria window, click Add to List.

Note, if you don’t want all the values, it may be quicker to select them
individually:

1. In the Matrix Coding Criteria window, for either rows or columns, choose
Attribute Condition from the drop-down box then click Select.

2. Choose in turn each value of an attribute you want as a row or column, and
Add to List.

Note the wording: in the example below I am asking for content coded by any case
where Education=primary.

To specify Tree or Free Nodes
1. In the Matrix Coding Criteria window, for either rows or columns, choose

Selected Items from the dropdown list.

2. Click Select, and then select the nodes you want.

3. To select all the nodes in a tree or subtree –click Automatically select
hierarchy then select the parent node and all the descendents will be
automatically selected. You can then unclick any child nodes you don’t want,
or Remove them from the Matrix Coding Query list.

4. Click OK.

5. In the Matrix Coding Criteria window, click Add to List.
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To specify the relation between rows and columns
1. In the Matrix tab, set the Search Criteria. For example, Search for content

of rows AND of columns if you want the intersection of the two.

You can choose from three Boolean operators – AND, OR and NOT and
three proximity operators – NEAR, PRECEEDING and SURROUNDING.

2. If you chose a proximity operator, select from the Options – e.g. how near is
NEAR? Below, the specification is Within same scope item. It will find for
example, for each cell everything coded at the row item if there is something
coded at the column item in the same document or node if they are part of the
scope you specified.

To set Query Options
1. Click the second tab, Query Options. As for any Query it provides options to

preview or save. But for Matrix, there is only one save option.

2. Select whether you will preview or Create Results as New Matrix.

A matrix is saved as a node for each cell. If you create results as a new
matrix, it will appear in the Results folder. You can move it to the Matrices folder in
Nodes if you wish to keep it. Or if you wish to alter the nodes that code the cells
separately, move it to the Trees area.
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2. Using your matrix.
For most qualitative research, the critical purpose of building such a table is to return
to the data and try to understand and interpret the pattern.

To save a previewed Matrix
If in the Query Options tab, you asked to Create Results as New Matrix, it was
saved either in Results or in the Matrices folder of Nodes. But if you selected
Preview Only, and now wish to create the matrix, it is not lost.

1. In the Detail View of the matrix, right mouse and select Store Query Results.

2. Locate and name the matrix and if relevant, store a description.

To work with the matrix
1. In the Detail View, first adjust the table so that the row and column headings

can be seen. (Go to Help for advice.)

2. Right mouse click and select Matrix Cell Shading. The matrix appears with
shading indicating density of coding.

3. Now explore the options to show in the cells – number of sources, or cases,
words, or coding passages represented there, and a choice of percentages.
Select the one appropriate to your purpose – the shading changes.

4. Right-click on a selected cell. Remember, it is a node, so you can open it in
the Detail View to see all the content coded at that cell’s node.

Thus the cell being opened in the illustration above will show you everything
coded at “sense of achievement” if it was said by a participant from Australia.

The contents are coded at a node for that cell, and you can code on from it just
as you would in any other node.
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5. Now, another toolbar. The Grid toolbar allows you to use buttons for common
tasks in any grid or table. As for any toolbar, check what the buttons offer and
tailor it if you wish. Or look for them on the right mouse button Context menu.

In the example below, the table is transposed, so attributes are columns.

The toolbar option to hide columns is being used to hide cases with primary
education, whilst the researcher concentrates on the difference between what
is said by the more numerous secondary and tertiary educated participants.
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3. Saving and exporting the matrix
Like Results nodes, Matrix nodes can’t be altered by you – to do this would be to
falsify the matrix. A matrix remains unalterable whether it’s in Results folder or the
Matrices folder of Nodes.

But if you move it to Matrices, this is a way of ensuring it is safe in your project. Like
any nodes, it can have a linked memo to describe the pattern you are seeing.

If you are interested in any cell or cells, and want to keep working with them as
nodes, copy them and paste into the Trees area, where they become “ordinary” tree
nodes, and you can code more at them or delete coding from them.

Using the matrix in reports
As you move through the processes of “seeing” the project, matrices may be very
important. You can keep them as nodes in your project, and view them on the screen
at any time. But you also can copy and paste them into a word processor report or
PowerPoint presentation.

 To view and use the content coded at any matrix cell, you can copy or print it
from the Detail View, or make a report on it as for any node.

 To print the whole matrix, from the File menu select Print. (Check first the
dimensions of this table: you might waste a lot of paper on a long thin table.)

 If you want to include it in a written report or a PowerPoint presentation, or to
import this data into another package, simply copy all the content and paste
into a Word document. you need to Export the matrix. In your class report or
project write-up, you can include this table since it can be opened in Word or
Excel.

To export a matrix
1. Select the node that contains the matrix (either in Results or Matrices folder,

as you specified) or select the matrix in the Detail View

2. Right-click and select the mode of export you wish (a text file or an Excel
spreadsheet file). The file will be saved where you specify.

3. Open the file in Word or Excel to use as you wish.
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You can very quickly build up a large node system by running matrix searches,
since each cell in a matrix is a node!

Ensure that you do some node housekeeping after running these searches. A good habit
is to move all matrices out of Results and into the folder for Matrices in Nodes if they
are of lasting value – and delete them if they are not.

This concludes Tutorial 9.

For more on showing and interpreting patterns in your data, go to Chapter 9 of
Handling Qualitative Data.

The final tutorial covers other aspects of reporting, ways of getting the results of your
analysis “out” of NVivo and into the report.
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NVivo 7 Tutorial 10:

Reporting and Showing Your Project
An important process in any project is the “telling” of your project, informally, then
formally in a written report. This is needed throughout, not merely at the final stage.
Researchers need to be able to report on and demonstrate each stage of a project, and
do so clearly and convincingly.

Properly accounting for and assessing your project requires a systematic record of the
data relevant to each stage in your analysis and the processes that are significant for
each small arrival at a hunch or a conclusion.

Qualitative research moves to creation of explanations or theories in a series of steps
and discoveries, building on previous steps and discoveries (Handling Qualitative Data,
pp 149-150). So these must be carefully logged, their justification must be
demonstrated and the accounts of the data supporting them must be thorough.

This final NVivo 7 tutorial suggests ways of using the software tools to report on your
data and analysis, extracting the appropriate material for use in your accounts of your
data and showing your conclusions and how you arrived at them.

Most software tools suggested here are familiar from earlier tutorials. (In each section
I introduce few new techniques). But researchers often fail to put them together to
make convincing reports.

In this tutorial you will learn how NVivo can help you:

 Keep and report a “log trail” of your project

 List and review the project items, their content and coding

 Take “out” data content into reports to illustrate or discuss

 Make formal reports on the state of the project

 Show the patterns of analysis in models

The final chapter of Handling Qualitative Data is on the “telling” of qualitative
research, including advice on doing a writing “stock-take” to learn from your logs
and memos and assess any weaknesses or gaps revealed, reporting results,
appropriately using quoted material to illustrate and strengthen your argument, and
making the all-important case that it is convincing.

The bringing together of your results will involve every part of your NVivo project.
To review what you need to know about the ways of seeing documents, nodes, models
and results of your searches, revisit Help.
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1. Keeping a log trail
To make your log trail as valuable as possible, explore the software processes that can
contribute. Your project log trail could use many of the techniques in earlier tutorials,
for example:

 A Project Journal, edited at various stages in your project to show the
progression of ideas, concepts and the state of your data. Use Links to other
data to keep in touch with the development of those ideas.

 Memos on key concepts or significant data sources. You can create memos to
capture your thoughts about data, concepts, research procedures and so on.
When a memo is related to (or inspired by) a particular source or node, you
can create a Linked Memo.

 Static models of important categories at various stages in your project. These
will remain as a record after project items or your interpretations are altered.

 Details of the results of the queries you have run at various stages of your
project and their contribution to your analysis. Store descriptions at the
Results nodes or memos if you move them into the Nodes areas.

Consider the following further techniques:

To link your trail to the data
Qualitative reports present a web of evidence. Webs are well kept on computer with
hyperlinks.

 Use See Also links to point from your memos or logs to the evidence they
refer to.

 Familiar hyperlinks are a simple way of keeping the threads of evidence
available to be followed. Hyperlinks can be imported in a Word document, or
added (and of course removed) in a source in NVivo.
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Warning: of course if web site addresses change or files are moved, hyperlinks are
broken. If you are linking to files that are stored on your computer and are central to
the project, create a special folder on your computer for those files, so you can move
them together with the project.

Consider using Externals to handle hyperlinks, especially if you are linking often to the
same site. An external can represent a web site (and contain your ideas about what is
there) and every time you want to link to it, you link to the external. If the hyperlink is
broken, you need only update it once, by changing the external file address.

To keep access to all materials for your Log Trail
Find and Query are tools you will use many times on the trail of hunches or
hypotheses. To keep a record of that trail is very valuable. It can be a memo on the
hunch or an entry in your Project Journal. Use the following techniques from earlier
tutorials:

 Make memos for significant results nodes. Use the fact that NVivo dates their
creation to keep the story of this search trail.

 Archive your plain language record of what you were asking via Query, and
what you found. Save Queries to rerun and assess their results in different
bodies of data – and keep a record of what you found.

 Store matrices in their own folder in the Nodes area and write memos for
them.

 Use the ability to make a Set of any sources or nodes to keep in one place
pointers to all the “log trail” items you will wish to access as you write up
your report.
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2. Listing and reviewing the project items
The project changes every time you have an idea. How to report adequately on this
shifting material?

The List View of any project items is the first place to go. In any List View, you can

 View and review all the items, opening them in Detail View as needed;

 Click at the top of a column to sort the items according to any column (here,
which interviews are coded at fewest nodes – should I revisit those?)

 If the items in a List View are sources and/or nodes, save the items as either a
set or a node or add them to any set or node. Use this to build another query –
how do these cases respond to a different question….?

To print or export a list
From any List View, you can print or export a list of the items in that window. To do
this regularly is a useful way of logging the development of relationships or nodes.
The list can be exported to Excel or Word as a table – and columns selected and saved
as a text document.

If you wish to print or export a list of all tree nodes, not only the ones currently
showing, open the parent nodes so the child nodes show in the List View. Alternatively,
click on the folder All Nodes and print from the list view.
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3. Printing, Reporting and reviewing your sample
You can print or export the Casebook that provides, in table form, the list of all cases
in your project and the values of all attributes that apply to that case.

1. From Tools menu, select Casebook>Open Casebook

2. The Casebook opens in Detail View. Use the Filter icon on any column to
show or hide cases to suit your reporting needs.

Note that only attributes whose values are numerical can be filtered with
requirements including “greater than” and “less than”.

3. In the Casebook Filter Options window, select which cases you wish to
show or hide.

4. From the File menu, select Print Preview if you wish check the dimensions
of what you are about to print. Either transpose the table or select Landscape
layout if the table is too wide for a page. Then select Print.

To list all cases with an attribute value
For many sample review purposes, you may require a detailed list of the numbers and
names of cases with a particular attribute value – e.g. how many women in your study
and who are they? This is a job for an Attribute Summary Report.

1. From Tools menu select Reports>Attribute Summary Report

2. In the Customize Attribute Summary Report window, select the attributes
and cases you want a report on. Click OK.

3. The Report opens on the screen. See below on handling Reports.
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4. Taking content “out” of NVivo
The usual edit tools apply in a source or node Detail View: copy and paste, using
icons or fast keys. Note hyperlinks remain live in pasted text if you copy and paste
from an NVivo source to a document in Word. But annotations are lost. If you want
the full detail of the text, it is better to export the item. You can export to a Word (or
.txt or .rtf) file.

A qualitative report should not be merely a patchwork of quotes. But of course you
do need appropriate quoted material. You also need to know where quotes came from –
context may be all important. Consider using a node for this purpose, coding there for
example “material to quote in current report”. The node Detail View shows the source,
and from the node you can jump to the context. You can export the node when you come
to write the current report.

Exporting project items
1. Select the source or node you wish to export.

2. From the Project menu, select Export Item.

3. Select the options you want. Click OK.

4. In the Save As dialog, specify name, location and type of file. Click OK.

5. Find and open the file. If you asked for Annotations or See Also Links
they will appear as endnotes.
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5. Making Reports
You can make more formal reports from NVivo on any aspect of your project.

These appear on the screen as formatted documents, and can be printed. If you want
to save and edit them, they can be exported as Word files, to be opened in your word
processor and incorporated in your writing report.

To make a report
1. From the Tools menu, select Reports.

2. Select the report you want: you can make a Project, Source, Node,
Relationship, Attribute or Coding Summary Report. And also the Coding
Comparison report described in Chapter 5.

3. In the Report Options window select – carefully – what is to be included.

The report appears on the screen and can be printed or exported. Note, the
reports generated from the Reports menu are not freely editable. for saving or
editing. To get an editable version, click the top left corner icon to Export Report,

and select to export to Word.
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6. Showing with Models
Finally, as you move towards a final report, use the visual ways of showing the
project in part or as a whole in static and dynamic models.

To use static models
Saved static models allow you to show visually the stages in your analysis. The model
made last month may contain nodes you have since merged or deleted, or
relationships that proved insignificant. They will not appear in a dynamic model,
since they are not in the project. But they are still there in a static model.

1. Click in the Detail View of the model you wish to save as static.

2. From the Project menu select Create As>Create As Static Model.
(Remember the advice in Tutorial 7 to make a special folder for static models.)

3. Name your model and describe it – so you’ll find it again and know why you
saved it as static. (Note its icon is different from the dynamic model’s icon.)

4. As you save static models, write a memo for each, summarizing why you
saved it, what it shows, and the changes between this and other models.

5. Use these models to display and discuss the development of your project.

To use dynamic models in NVivo displays
For an onscreen display, or a projected illustration of a report, consider using NVivo,
rather than the standard format of PowerPoint.

1. Make a model that summarizes the aspects of your project you wish to
address.

2. Make groups to represent the stages or parts of the project, and display them
separately, then together, as you tell its progress.

3. Place in the model a node that codes critical quotations; open that node from
the model when you want to show the data behind your conclusions.

To copy models into other applications
1. Select all of a model (Ctrl+A) or part (select just the items you want) and from

the right mouse context menu or the Edit menu or toolbar, select Copy.

2. Go to the location in another file – a word processor document, PowerPoint
slide, etc, and there select Paste.
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3. The model appears in the new location with color, shading and detail as it was
in NVivo. (Note it is not dynamic – the items are not live to the data, and can’t
be moved around.)

This concludes the final tutorial in NVivo 7.

Go to Chapter 10 of Handling Qualitative Data for advice on logging your project,
reporting your progress and justifying your conclusions.

Go back to the introduction to this series for advice on further sources of information
about research processes using the software, and ways of working further with it.

Happy researching –
and please don’t forget

to back up your project!!


