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Teach-yourself NVivo 8: 

the introductory tutorials 

Lyn Richards 
 

Welcome to the ñdo-it-yourselfò tutorials for researchers and students who wish to learn NVivo 8. 

These ten tutorials take you through the basic functions of the NVivo 8 software, with guidance to 

its interface and processes, as you set up and commence your own project. These are edited versions 

of my tutorials for the earlier NVivo 7, with new illustrations to show the new ólookô of the 

software and additions for new functions. My thanks to Sue Bullen and Fiona Wiltshier from QSR 

for making these alterations and checking that the tutorials properly represent the current software. 

You can use these tutorials alone, or use them with the chapters of my book, Handling Qualitative 

Data: a practical guide, London, Sage, 2005. In my experience of designing and teaching software, 

researchers often need methodological discussion of the software processes they were learning. 

Thereôs no point in learning a technique if you canôt see why you would want to be doing that, and 

thereôs danger in using software if you have not considered the possibly unintended consequences. 

So each Tutorial explores in software the techniques and processes described in a chapter of the 

book. Those chapters give advice and help with the research processes the software supports: 

http://www.sagepub.co.uk/richards/. 

 

For more qualitative resources, go to www.lynrichards.org. 

I have prepared these materials for websites to provide widest possible access to detailed help for 

qualitative software self-teaching, and for use by those teaching software to others. They are 

however copyright, to ensure that if they are reproduced, this is done in adequate context. Of course 

permission will be given for copying them in appropriate contexts. So please just email me if you 

wish to use them in this way. 

© Copyright 2008 Lyn Richards  

These tutorials are copyright to ensure that they are not reproduced partially or in ways that distort 

their content. They may not be reproduced without permission. 

Please contact me at info@lynrichards.org if you seek permission to reproduce them in a research 

or teaching situation. 

http://www.sagepub.co.uk/richards/
http://www.lynrichards.org/
mailto:info@lynrichards.org
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The NVivo software 
The software used in these tutorials is the latest version of NVivo, NVivo 8. You will need to have 

a copy of the software to build your own project, using these tutorials.  

If you are working with the earlier version of the software, go to the tutorials for NVivo 7. 

If you or your institution has no access to a license for NVivo 8, you can still find how it feels to 

work in the software by using the free (time-limited) demonstration version available from the  

QSR website. 

For those who wish to compare NVivo 7 and NVivo 8, the two groups of tutorials are identical, so 

you can skim to see whatôs new. 

Data for your project 
The exercises for each Tutorial assume that you have data records available to you. There are many 

ways of making that data. 

NVivo 8 ships with a copy of a project called Volunteering, which I created for the softwareôs 

online documentation. You can work with this sample project, if you wish. The files include 

interviews and focus groups as well as memos about the project, and you can use them to start your 

own project. You might conduct an interview of your own to explore attitudes to volunteer work 

amongst your family or friends. Now use the data to answer questions of your own. The 

volunteering data will be used in illustrations during these tutorials.  

Alternatively, you might make a very small exploratory project with your own data. For these 

tutorials you need only a first research question and a few documents ï five hour-long interviews or 

field note reports would be fine.  

You can import existing data from any Word files. Or, if you wish to invent a small project for 

these exercises, go to Handling Qualitative Data, Chapter 2 for discussions of some of the many 

ways of making qualitative data, with references to other texts for detailed advice. In Chapter 3 is 

advice on making data records that will be rich and useful for your project. 

http://www.qsrinternational.com/
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Using these tutorials 
The ten tutorials can be followed by individual users working alone, or they can be incorporated in 

class laboratory sessions alongside the book chapters. They donôt explain the purposes of the 

processes they teach, but there are explanations of each in the chapter of the same number in 

Handling Qualitative Data. 

Chapter summaries and software tutorials 

 Tutorial 1   Setting Up Your Project 

 Tutorial 2   Creating and Importing Sources 

      Tutorial 2a  Making Multimedia Sources 

 Tutorial 3   Managing data: Cases, Attributes and Sets 

 Tutorial 4   Editing and Linking: Getting ñUp From The Dataò 

 Tutorial 5   Coding, and Working With Coded Data 

 Tutorial 6   Relationships and Other Nodes: Handling Ideas 

 Tutorial 7   Seeing It In Models 

 Tutorial 8   Finding Items and Querying The Data 

 Tutorial 9   Exploring Patterns in Matrices 

 Tutorial 10   Reporting and Showing Your Project 

 

I hope the tutorials, and the book, continue to be useful to researchers learning techniques for 

doing justice to data.  

 

 

Lyn Richards, 

Melbourne, October, 2008. 

info@lynrichards.org. 

mailto:info@lynrichards.org
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NVivo 8 Tutorial 1: 

Setting Up your Project 
 

This tutorial is about starting out in software.  

Starting out is not a very predictable experience, since many factors affect confidence and success. 

These include obvious variables like experience and competence with computers, familiarity with 

the purposes of qualitative research and resources of time and assistance. But none of these is an 

overwhelming requirement! Success will be most directly a result of your own efforts to see the 

purpose of each exercise and to do it yourself.  

The exercises in this tutorial have two purposes: setting up your own project (and getting familiar 

with the software) and ensuring you can save, close and open it. 

They start with ways of meeting the software through the online resources that come with it. There 

are Getting Started self-running tutorials provided, which will help you to learn how to use the 

menus, and the uses of the different folders in the Navigation View.  

Following this introduction, there are instructions to set up your own project, and to familiarize 

yourself with where your data and reflections will be stored. An introduction is provided on using 

Help and customizing the software to suit your style. 

As you work through this first tutorial, take notes of any processes you donôt understand or want to 

explore further.  

For advice on the early processes of a project, logging the plans and the journey, entering the field, 

declaring the assumptions you bring with you, and learning the software tools you will use on the 

way, go to Handling Qualitative Data, Chapter 1. 

For assistance with the basic software processes, use the online Help. A section of this tutorial 

introduces it. 
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1. Meeting the software  
At this stage you need an overall familiarity with the tools offered by your software.  

If you have access to an introductory class or workshop, this gives the easiest first encounter with 

the software. Watching someone who knows it will quickly show you how to use it. 

If you are teaching yourself, use the Getting Started Guide and the Tutorials provided with the 

software.  

To access the Tutorials: 

1. NVivo 8 should be installed on your computer. This will be done from a CD or by download 

from the QSR website. 

2. Start the NVivo application by clicking the desktop icon (or via Start>All 

Programs>QSR>NVivo 8>NVivo 8). The Welcome screen shows a list of recent projects 

which includes the sample project and any other projects a user might have created.  

3. On the menu bar, select Help  and then NVivo Tutorials. There are four Tutorials, which run 

automatically. Further tutorials will be developed and available for access via the QSR 

Website. 

 

4. On the left hand panel, select the tutorial called The Workspace. The messages appearing on 

the screen will explain the features of the NVivo workspace. 
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2. Setting up your own project 
The next task is to set up your project ready to receive your data sources and ideas. 

To create a project 

1. Whether you just launched NVivo, or just closed a tutorial, the NVivo Welcome screen is 

displayed. 

2. Choose New Project from the File menu 

3. Type in the name of your project and a brief description. Note that unless you choose a different 

location, the project will be stored in your ñMy Documentsò folder (or Documents if you are 

using Windows Vista).  You can change the location of your new project by clicking on the 

Browse button in the New Project dialog box. (If you want to move or copy a project after you 

have created the project, then you can do this from Windows Explorer just like any other data 

file.) 

 

4. Once you click OK in the New Project dialog box, your new project is created and the NVivo 

Navigation Window opens. On the title bar at the top of the window will be the name of the 

project you created. (In the illustration, it is called ñExploring Volunteeringò). 
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Getting to know the Navigation Window 

This window will be home base for your project. Its left hand side folders store all the data items 

you create or import, and its right side panes list those items and display their contents. (Currently, 

thereôs nothing there to show.) 

If you are using MS Outlook, this window looks very familiar. Itôs meant to do so! For the life of 

your project, it will be the way you access data items and content. 

In the folders on the side you can store all the data and explorations of a project. 

 

As you create data and 

start analysis, there is a 

place for each item in 

these folders.  

 

 

 

The List View  of items, 

and information about 

them, will appear in this 

space when you click on 

any folder. The List View 

has a new feature that 

enables you to add/remove 

columns on display. 

 

.The Detail View of the 

contents of an item will 

appear below that list when 

you double click on any 

item in the list. 

Setting up your project, you can 

in Sources, put your data documents, memos and media files. 

in Nodes, store ideas and coding; 

and in Sets, group those sources and ideas. 

Then, as your analysis progresses, you can 

make Queries to ask questions of your data; 

in Models, make diagrams and images; 

use Links  to connect data items and content, 

and make Classifications for attributes and  relationships.  

 

 

 

And in the panels on the right hand side of the Navigation Window, 

you will be able to see and manage the contents of any folder ï listed, 

or shown in detail. 
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3.  Using Help 
1. Click on the Help menu, this time to access the Online Help. You can also access the online 

help at any time by clicking the question mark (?) in the dialogue you currently have opened ï 

this will take you directly to the help for that item. 

  

2. Take time to check the Help contents. Note that there are two parts. 

¶ In the sections on Using the Software you will find instructions for conducting each task or 

process in NVivo 8.  

¶ Go to the topic on Navigating NVivo and read the subtopics about introducing and customizing 

the workspace. 

¶ The sections called Working with  Your Data offer advice on why you would be doing this, 

and how to use these tools in your project for your analysis goals. 

¶ Go to the topic on Approaching an NVivo Project. Read about what it is like to work in 

NVivo 8. 

3. Click the Search tab and try searching for information about some of the processes you are 

about to conduct. Note that each topic takes you to information about using the software and 

working with your data. 
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4. A first step to customizing NVivo  
Qualitative researchers often care about the way their data records look, and the appearance of the 

screen they are working on. 

1. In the Navigation Window, you can change how the folders appear (just as in MS Outlook) by 

selecting to show and hide them or see the subfolders all together. 

2. You can undock (and re-dock) the Detail View, making it a free-floating window, whenever you 

want to concentrate on just one item ï to do this, click Docked in the Window menu. 

3. And importantly, you can change whether you see the panels of the Navigation Window with 

the Detail View below the List View, or on the right hand side. Experiment with different 

layouts especially when you start coding. 
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5. Your project and its management 
Now, to your project. Your NVivo project is stored as a single file. The File menu allows you to 

make a new project, open your existing project or close it.  

Note the options available from the File menu. 

  

From this menu you make a new project, open an 

existing one, make a copy of a currently opened 

project or import one project into another.  

If you are working in a team you may later wish to 

combine your projects in one. By importing one 

project into another, you can merge your work. If you 

wish to do this, go for advice to the Help topics on 

importing projects. 

The File menu also gives access to the Project 

Properties. Here you can change the name or 

description of your project. 

 Note, if the name is changed internally, the 

projectõs file name on your computer hard disk will not 

be changed. 

To close and locate the project  

1. From the File menu select Close Project.  

2. If you have made any changes to the project, you will be asked whether you wish to save this 

project, choose YES. 

Congratulations! You have a new, saved project, waiting for your data and ideas. 

Your NVivo project database is saved in a single file.  By default it is in the My Documents (or 

Documents if you are using Vista) folder. (If you changed this default, or move it at any time, 

be sure to record where you placed that file.) Your new project should now be stored in the 

location you specified. 

3. Go to the Windows Explorer and the folder for My Documents (or Documents) to check your 

project  is where you put it. It is a single file with the NVivo icon and the extension .nvp (for 

ñNVivo projectò). Like any other file it can be copied, moved or sent to a colleague.  

To open and save your Project 

1. When you closed your project, you returned to the Welcome window, which now shows the 

name of your project. Click on its name. Your project will open in the Navigation window. 

Note that on the File menu, Save Project is probably not available, because you have not made 

any changes to save.  

2. From the File menu, select Project Properties. The window tells the name and description you 

gave your project, and the time you created it. Alter the description to add detail. Now, you have 

made changes and can select the Save Project option, or simply use Ctrl+S .   

 Make a habit from now of doing a Save whenever you feel you have significantly changed your 

project.   
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To manage saving and undoing 

NVivo has Undo ï more on how to use it below. After you save changes, they cannot be undone.  

For this reason, NVivo will not ñautosaveò. Rather, it will ask, at regular intervals, if you wish to 

save. (You can change the frequency of reminders ï see next section on Options). Always consider 

your answer, as you may wish to Undo something you just did.  

 

 

 

When you close a project, if any changes have been made to it, NVivo will ask you if you wish to 

save changes.  

To back up your project file 

There is great advantage in having your project saved as a single file. It is much less likely to be 

damaged by bad file management than a project saved in many folders. Also, you can easily send 

the entire project to a colleague or supervisor as an attachment to an email. If it gets big, compress 

the file using Winzip. 

You back your project up like any other file.  

When you wish to back your project up 

¶ use whatever is your normal backup procedure to make a copy of the project file on 

another safe storage device; 

¶ or if you prefer, whilst you are working in your project, make a copy of a project 

from the File menu. (Simply select File>Copy Project). 

 

Always back up your project frequently, and keep a record of where you stored the backup copy, 

and of other relevant information about date, state of project at backup, in case of computer 

problems or change of direction in your thinking. When you are working qualitatively, you can 

change the project data base very many times in so many minutes! Like any computer file, your 

project can be deleted or mislaid if you are not careful with your data management processes.   
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To set application options for save and safety 

1. From the menu bar select Tools>Options . The Application Options window opens. Click the 

Notifications tab and set the project save reminders to the time you prefer. 

2. Click through the tabs to check the range of project options you can set.  

 Big Warning ! one option is Enable deletion confirmation messages.  Unless you are very 

confident, donõt un- tick it!! For most users, it is essential to have that warning when, unintentionally, 

they have asked to delete items.  

 

 

3. Note the button Clear Recent Project List on the General tab. Youôll be needing this! Use 

it when you wish to clean up the Welcome Windowôs list of projects after you remove 

experimental old projects, or move ones you are working on. 

This concludes NVivo 8 Tutorial 1. Go to Handling Qualitative Data, Chapter 1 for advice on any 

of these research processes..  

Now for some data! In Tutorial 2, youôll make documents in three different ways ï and back up the 

now growing project. 
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NVivo 8 Tutorial 2: 

Creating and Importing Textual Sources 
 

This tutorial is about how to make textual data records in NVivo 8, or import them into your NVivo 

project. There are three ways of doing this ï in this tutorial there are instructions for each. You will: 

¶ import  one or more records from a word processor file; 

¶ work in your project, and create a record there;  

¶ record a summary of whatôs in an External record. 

And since at the end of this tutorial you will have a project underway, it concludes with instructions 

for a fourth task: 

¶ back up this precious project file that records your work! 

Chapter 2 of Handling Qualitative Data is about making qualitative data, the many ways of doing 

so and how to make useful data for your purposes. To review what you need to know about 

documents, go to the Online Help.  

About textual sources: documents, memos and externals 
NVivo provides three folders for three sorts of Sources ï internals, memos and externals. 

These are common divisions in a qualitative project. You can make further sub-folders of your own 

to hold different types of Sources. Internals, for example, may be divided into interviews and focus 

groups, or memos into theoretical and methodological notes. 

Each óInternalsô folder can hold both textual and multimedia records, in this tutorial we are going to 

focus on working with textual records, to see how to work with multimedia records, see Tutorial 2a. 

If you are working in NVivo you can write early research design records or letters etc. in a word 

processor and import them to your new project as documents or memos. Or simply write them 

within your project.  

And you can make ñExternalò sources to represent other material that you will not bring into the 

project at all but donôt want to lose. 

This tutorial takes you through the steps to import a document, to create a document in NVivo and 

to create an External to record other data. 

As you work through these steps, note that there are always at least two ways of getting to the 

commands you wish to give the software. Familiarity with these different ways of working with 

software will help you find the way that suits you best.  

 Use the List View, as you work. L ike the familiar Windows Explorer,  it  will allow you to sort on 

any of the columns in the right pane . As you bring in more sources, you can view your documents or 

externals in order of size, amo unt of coding, or date created or modified.  
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1. Choose how you work in NVivo  
Most tasks can be accessed via the top level menu and also the context menu available from the 

right-mouse button. For most menu items there are short cuts. And for some there are icons on the 

tool bars. For example, there are always three ways to add any new item.  

You first need to tell NVivo what you wish to add. You do this by clicking on the appropriate 

folder, and then clicking in the right pane List View . Now what you can do for that sort of item will 

show on the Project Menu and the Context menu when you click the right mouse button. 

 

1. Go to the Project menu 

and you will find it offers 

the option to create a new 

internal item (or import 

them). 

  

2. Or right click in the 

List View and from the 

right mouse Context menu 

select the option to add a 

new item of that sort (or, 

for documents, to import 

them). 

 

3. Or just use the New 

button to create this sort, or 

any other sort of new 

project items.  

 Have you noticed that 

most common act ions in NVivo 

have fast keys showing with the 

menu items? It is useful to 

learn the ones you will often 

want to use.  
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2. Making sources 
Most of the data sources in most qualitative projects are recorded in text. At this stage, you may 

have early research design documents. Later, you can add transcripts of interviews, field notes, 

survey responses etc.   

As those documents are created, they are usually typed up in your normal word processor (here we 

will assume itôs MSWord.) These word processor documents can be imported directly into your 

project in NVivo. They can be in Word files (.doc or .docx) or in rich text format (.rtf) or pdf format 

(.pdf) or of course in plain text (.txt). If you use Word files, they can include pictures or tables or 

other embedded objects, and you will be able to view, code and retrieve this content. 

To import a document 

1. Create a document in your word processor, or locate one you have already typed up. Or write an 

informal one about what you are planning to do and call it something like ñProject Journalò. 

Save it as a Word (.doc or .docx) file, in a sensible location.  

2. In your NVivo project, click on the folder for Sources, and then  Internals . Click in the List 

View to show you want to work with the items in that folder. From the Project menu select 

Import Internals . (Or select this command from the context menu when you click your right 

mouse.) 

 

 

 

3. Note the options offered. The option to Code sources at new cases is covered in the tutorial for 

Chapter 3. If you are importing documents (e.g. interviews) that represent cases for which 

you want to store information, go to that tutorial to read about cases. 

4. Click Browse to select the file to import. Navigate to where your first source file is located. 

Select it, and click Open. (If you have prepared more than one document, select with 

Ctrl+click  or Shift+click  to import many documents at once.) Click OK . 

5. The Document Properties are shown. By default, the name of the document is the name of the 

file selected. You can rename or re-describe the document at any time by going to its Properties. 

6. Click OK . Your document is imported and its name and details appear in the List View .  To 

read it, double click on the icon next to its name, and its contents will open in the Detail View 

below. 
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If you wish, you can edit the text, cut and paste text or images, change colors and fonts etc just as 

though you were in a word processor. Close the Detail View at any time by clicking on the X in the 

top right corner of the detail view. 

To add a new source in NVivoôs editor  

Documents or memos can also be introduced into a project by transcribing directly into NVivo.  It 

has a rich text editor, with font controls, and Undo. (Though of course it does not have full word 

processor functions like spelling checkers.)  

Now consider a memo you wish to start. Perhaps a record about your own attitudes (prejudices?) to 

what you are researching? This may be a first important contribution to your projectôs logging 

process. Once itôs created in NVivo you can continue to enter into it all the changes in your views 

(or confirmations of them) that should be logged.  

As youôll see in later tutorials, there are huge advantages in typing directly into NVivo. Any log 

trail document can be linked to the data it describes and you can code as you type. But for now, just 

start it. 

1. In the Navigation window, click on the folders for Sources and then Memos. Remember to 

click in the List View to tell NVivo you want to work with the items in that folder.  Now 

you can use the menus as before: click Project>New Memo or use the context menu or the 

New button.  

 

2. In the New Memo window, name and optionally describe your memo.  

 

 Descriptions matter ! NVivo gives a description op tion for most project items. Always use this if 

your purpose in creating an item (like a memo) may be forgotten or confused. Teams are much helped 

by storing descriptions to convey purpose.  
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3. Click OK  and the memo is created. The content (currently none) opens in the Detail View Type 

oné you are in NVivoôs rich text editor so use heading styles, italics, bold or color as you wish. 

(Advice on starting a diary or journal document is in Chapter 1 of Handling Qualitative Data.) 

4. Itôs important to date the entries in any project journal Note that you can time-stamp your 

entries by selecting Format >Insert> Date/time, or just hitting Control+Shift +T . 

  

 

5.  Close the memo as you would in a word processor, by clicking the corner X in the title bar. 

Changes will be automatically saved but remember to save your project as a whole hit Ctrl+S. 
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3. Recording external data  
Now for data that is not easily brought into NVivo. As noted in Chapter 2, qualitative data records 

are rarely homogeneous. Much of your data will not be textual.  

For the project you proposed, find some data that you do not want to bring into the computer, or 

canôt ï e.g. webpages, books, or a box of newspaper cuttings.  In NVivo, such data can be 

represented by ñExternalsò. If the data represented is a file on your computer itôs called an 

ñexternal fileò because it will not be in your project. If itôs not on your computer, itôs termed non-

file data. 

To add an External for a book 

If you are stuck for some external data, make an External for Handling Qualitative Data. Any 

project requires work with literature, and with an External you can reference and keep connections 

with books and articles. Your summary of each chapter, with occasional quotes, is a Source for the 

project; you can link it to relevant data in your project and use coding to find the passages when 

they are needed. 

The process of creating a new item should be familiar now ï select the folder you will create it in, 

(Sources and then Externals) click in the List View  to show you want to work with the items in 

this folder.  

1. From the Project menu (or the context menu), choose New  External (or use the New button: 

New>External in this folder). 

2. Type in the name and any relevant details. 

 

3. Click the External tab to specify the file type ï this can be a file link or web link. If you are 

describing something (like a book), that is not a file on your computer or a URL, select Other.  
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4. If you wish, specify what the contents are, the unit (e.g. chapter) and the range  

(e.g. chapters 1-10).  

 

5. Click OK . Your External appears, ready for you to type in summary or comments. If you asked 

for numbered units, you have a template into which you can type the summaries of your 

external data. Each chapter (or other unit that youôve specified) has its own paragraph, so you 

can put the summary or your comments at the appropriate place. 

 

6. As before, just type as though you were in a word processor, changing styles, fonts, etc as you 

wish. You can insert hyperlinks to a website or images from the book. In the later tutorials to 

Chapters 3 and 5, youôll learn how to link and code this different sort of data. 



Teach Yourself NVivo 8: tutorials by Lyn Richards      22 

 

To add an external for a website 

This is a very common requirement ï you have found a site and wish to keep the link to it and 

record your notes on the content. Make an External for that website and you can at any time jump to 

the site from your NVivo project. 

1. Youôve found the website and copied the URL. As above, Add External . Type in the name and 

description. 

 

2. Click the External tab to specify the type and location of this source. Contents or units are not 

relevant for a site ï simply leave these options. Click OK . 

3. The External opens in the Detail View and you can type your summary or reflections. You can 

copy and paste images into your External if you wish. 

 

 

 

 

 

 

 

 

 

 

 

 

4. From the List View you can at any time Open External File ï (from the Project menu or Context 

Menu). This calls the website (if your computer is connected to the web). 
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4. Saving and backing up 
A reminder: NVivo has saved your project in a single file. This single file can now be stored on a 

CD, Zip Disk, Network drive or emailed to a supervisor or colleague. 

1. Save and Close your project.  

2. In the Welcome Window, select File>Copy Project and follow the directions to make a copy of 

your project. 

OR 

3. Find the project file in your My Documents (or Documents) folder, and make a copy of the file. 

 

OR 

4. If you are currently working in your project, choose the File>Copy Project. Hint: Add a date to 

the file name so if you do need to revert to an older version, you can locate this easier. 

5. Now, save the copy somewhere other than on your computer hard disk, for backing up. 

 You havenõt created a secure backup until this backup file is copied elsewhere.  A backup on your 

hard drive is a copy not a backup ð reflect on what happens to it if your hard drive dies or your 

computer is stolen . 

This concludes NVivo 8 tutorial 2. Go to Handling Qualitative Data, Chapter 2 for advice on any of 

these research processes. 

You now have a project with textual data, and a good routine for keeping it safe! In the next 

tutorial, youôll learn how to make multimedia sources. 
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NVivo 8 Tutorial 2a 

Making Multimedia Sources 
 

This tutorial is about how to work with multimedia data directly in NVivo 8.  You can choose to 

work with digital data such as audio, video or image files.  In this tutorial you will learn how to: 

¶ import  multimedia records; 

¶ create or import  text records associated with the multimedia sources 

About multimedia sources:  
NVivo allows you to import multimedia files into folders in the Internals area along with your 

textual data.  For instance you can import audio files for one interview together with the textual 

transcript of another and store them in the same folder for easy access.   

These multimedia sources can then be transcribed, annotated and coded using the same methods as 

when working with text data.  

 

This tutorial takes you through the steps to import a multimedia source and to create and/or import a 

text record associated with a source.   

1. Importing multimedia sources 
If you have data recorded in digital format such as audio, video or image files, you will be able to 

import it directly into NVivo.  NVivo allows you to import video files and media clips in .mpg, 

.mpeg, .mpe, .wmv, .avi, .mov, .mp4 or .qt format, audio files in .mp3, .wma or .wav format and 

digital photos and pictures that are in .bmp, .gif, .jpg, .jpeg, .tif or .tiff format.  

To import a media or image source 

1. In your NVivo project, click on the folder for Sources, and then Internal s. Click in the List 

View to show you want to work with the items in that folder. From the Project menu select 

Import Internal s. (Or select this command from the context menu when you click your right 

mouse.) 

 

2. Note the options offered. The option to Code sources at new cases located under has been 

covered in the tutorial for Chapter 3. If you are importing sources (e.g. interviews) that 

represent cases for which you want to store information, go to that tutorial  to read about 

cases. 
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3. Click Browse to select the file to import. Navigate to where your source files are located. Select 

the file(s) you want to import, then click Open. (If you want to import more than one source at 

the same time, use Ctrl+click  or Shift+click  to select and import many sources at once.). 

4. Click OK . Your sources are imported and their names and details appear in the List View .   

5. To open a source, double click on the icon next to its name, and its contents will open in the 

Detail View below.  

 

Storing multimedia source files 

As video and audio sources can both be large in size, NVivo offers options either to embed the 

entire source in your project, or to store the media file outside the project.  If the file is stored 

outside the project, as long as the file path is available, the source will work the same way as if it 

was embedded.  If the location of the project and/or the location of the stored file is changed, the 

file path may need to be re-specified.   

The default limit for files to be automatically embedded is set at 20MB. This can be changed if 

required through File>Project Properties>Audio/Video 

 

 

 

Note that the setting chosen applies to both audio and video files.  

To change the location of a specific file, right click on the source in the List View and choose 

Video Properties, then the Video tab. 

 

To embed the file in the project, click on the option Embedded in project. To store the file outside 

of the project, click on Not embedded ï file location, then click on the Browse button to navigate 

to the location of the file. 
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2.  Working with images 

Once you have imported an image file, you can choose whether to add text or comments about the 

image as a whole, or about sections of it. 

1. When you open the image source, the image is displayed on the left hand side of the Detail 

View and the log for the image is displayed on the right hand side.   

 

 
 

The log enables you to make notes or comments as required.   

 

If you do not want to use the log, you can hide it from view through clicking View>Log. 

 

2. To enter a note or comment about the whole image, click in the Content field of a blank row of 

the log and type in your text.  A new row is created to store your text.  

 

 
 

3. To enter a note or comment about a specific section of the image, first click and drag to select 

the required region on the image, then right click in the selected region and choose Insert Row. 

 

4. A new row is created in the log which specifies the selected region in the Region field.  Text 

can then be entered into the new row as required in the Content field.   

 

To view the region a log entry refers to, click on the row in the log and the selected region is 

highlighted on the image.   
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3.  Working with video sources  

Once you have imported a digital video file, double click on the source in the list view to open it.   

 

1. When you open the source, the video is displayed on the left hand side of the Detail View and 

the transcript  for the video is displayed on the right hand side.  The timeline is shown across 

the top of the Detail View, with the waveform displayed.   

 

 
 

The timeline indicates the time for any section of the video and enables you to navigate to a 

specific position as required.  

 

The transcript enables you to make direct transcriptions and / or make notes or comments as 

required.   

 

If you do not want to use the transcript, video or waveform, you can hide one, two or all of them 

from view by clicking on the relevant option(s) on the View menu 

 

2. To play the video, click on Media>Play.  

The playhead will move along the timeline as the video plays.   

 

3. To move to a different section of the video, click on the playhead and drag it to the relevant 

place on the timeline, the video will then commence playing from this point. 

 
You can work with the video file directly in NVivo and/or you can choose to transcribe the content 

and/or make notes on the content.   

 

Creating transcripts 
 

1. To enter a note or comment about the whole video, click in the Content field of a blank row in 

the transcript and type in your text.  A new row is created to store your text.  
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2. To transcribe or make notes on a particular section of the video, click and drag with the mouse 

on the timeline to select the required section, right click in the section and choose Insert Row.  

 

3. A new row is created in the transcript which specifies the selected section of video in the 

Timespan field.  Text can then be typed into the Content field of the new row as required.   
 

To view the section of the timeline a transcript row refers to, click on the row in the transcript 

and the selected section of video is indicated by a pink horizontal stripe shown below the 

timeline.  

 

 
 

There are a number of different methods to use when transcribing your video file within NVivo.  

For further details see the online Help. 

 

 
Importing transcripts 
If you have already transcribed the content of your video file, the transcript can be imported directly 

into the transcript area of your source.   For details of the formatting required to do this see the 

online Help. 

 

1. To import a transcript, open the video source within your project, then click on Media>Import 

Transcript Entries  

 
2. Click on the Browse button and navigate to where you have stored your transcript.  Select the 

required document and click OK . 

 

 
  

3. Click OK   

 

If you already have transcript entries in the source, NVivo will ask whether you want to proceed 

with the import. If you choose OK, the new entries will be imported and ordered by timespan 

together with any existing entries. 
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4.  Working with audio sources  

Once you have imported a digital audio file, double click on the source in the list view to open it.   

 

1. When you open the source, the transcript  for the audio is displayed in the bottom half of the 

Detail View and the timeline is displayed across the top, with the waveform behind it.   

 

 
 

The timeline indicates the time for any section of the audio and enables you to navigate to a 

specific position as required.  

 

The transcript  enables you to make direct transcriptions and / or make notes or comments as 

required.   

 

If you do not want to use the transcript or waveform, you can hide one, or both, of them from 

view through clicking on the relevant option(s) through the View menu 

 

2. To play the audio content, click on Media>Play The playhead will move along the timeline as 

the audio plays.   

 

3. To move to a different section of the audio, click on the playhead and drag it to the relevant 

place on the timeline, the audio will then commence playing from this point. 

 
You can work with the audio directly in NVivo and/or you can choose to transcribe the content 

and/or make notes on the content.   

 

Transcripts can be created or imported in the same way as for video transcripts (see the previous 

section of this tutorial for details). 
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NVivo 8 Tutorial 3:  

Managing data: Cases, Attributes and Sets 

 
For most new researchers an early concern is to learn the ways data are recorded. One aspect of this 

process is to store the context and the sometimes complex information that you have to accompany 

the qualitative data sources you are gathering via discussions, interviews or field notes.  

In NVivo, you can store such information as Attributes  of your cases, that is, the sites or 

individuals you are studying.  

In this tutorial you will learn how to 

¶ make case nodes to gather all the material about a case, and create the relevant values of 

variables, such as gender = female;  

¶ create attributes and store the values for cases in NVivo; 

¶ import a table of attribute values; 

¶ and ñtidyò sources and nodes into Sets. 

Chapter 3 of Handling Qualitative Data is about the importance of making good data records, storing 

the information about cases which may be essential for your analysis and managing the data 

records.  

For more detail about Attributes and Sets, go to the online Help. 

Thinking nodes and coding 
Nodes are containers for categories in your project, ideas or topics you are interested 

in. They can store references to data segments about any topic or concept. So they do 

what for most researchers is a most basic task of all qualitative projects ï bringing 

together the relevant data content for a question or reflection. 

You gather data together by coding those segments at a node. You can then view and 

review all of the data coded at a node. 

Nodes and coding are the subject of the next tutorials. Most of the coding you do at 

nodes will be interpretative ï recording your interpretation of the selected data and 

gathering everything about a topic at a node.  

But nodes also have many important data management roles. They can hold all the 

answers to a particular question or store all the results of a query. And most 

obviously, they can hold all references to data about a case. In NVivo, any case for 

which you wish to record attributes is given a Case node.  

 In the previous tutorial, when you imported documents, an option was to Code sources at cases . 

If you are importing sources (e.g. interviews) that represent cases for which you want to store 

information, you simply select that option and the whole source will be coded at a case node with the 

same name. 
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Cases as data containers 
In the Navigation Window, the second folder is for Nodes. This has five folders for different sorts 

of nodes. One of these is for Cases. In that folder, you can make new items. A new case will be 

represented by a node. 

 

Sometimes, a case is represented by all of and only one source (for example in a project where 

interviews were conducted just once with each person). But this is unusual in qualitative research. 

More often, you have material about a case from bits of many sources, (a joint interview with a 

colleague, field notes on a meeting, bits of a focus group). To gather all that material about the case, 

you code it at a Case Node. Then you can see it all together and ask questions about it. You can 

also store information about the attributes of that case ï e.g. this is a female, unemployed. Then, 

when you wish to find what unemployed females said about an issue, NVivo can locate all of the 

data coded at cases for which gender (attribute) = female (value).  

To design cases for your project 

For your own project, ask, ñWhat is a Case in this project?ò Try these ways to the 

answer: 

¶ What is the project about?  

¶ What places or institutions or individuals are you asking about?  

¶ What classifications are relevant? What sort of information do you 

want to store, and what cases have that information? 

Almost always these questions focus the study. If you are comparing schools, 

according to their socio-economic status and staffing profiles, schools are cases for 

this study. Code all the material about each school at its case node, and store there its 

attributes. Now you will be able to ask the comparative questions. (Did staff of 

working class schools have different attitudes to discipline?) 

As you build more data about a school, you can code it at the relevant case node. The 

attributes recorded for that node will automatically apply to the new material.  

 

 You can arrange cases in sub-groups, each under a more general case node. (A good design in the 

Sample Project would be to make case nodes for òFocus Group Participants ó and òInterview eesó. And 

perhaps to have another nod e for cases of òCompaniesó working with volunteers.)  
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1. Bringing more data into your NVivo Project 
To start this tutorial, prepare at least two more data sources, each of which represents a case, for 

example audio files or transcripts of interviews, each with one person. If you have no such data 

records yet, create documents from other sources, like website descriptions of relevant people.  

To import sources and create case nodes for them 

1. Import more sources into your NVivo project, following the instructions in the previous 

tutorials.  

2. At the Import Internal(s) window, click the option to Code sources at new cases located under 

Cases for any source for which you want to store attribute values.  
 

 

 

 

 

 

 

 

 

 

(If you want to put these new nodes under case nodes for each type of case, click Select and select 

the node, e.g. ñIntervieweesò, ñFocus Group participantsò, ñCompaniesò). 

3. Click Browse to locate and import the source(s). In the Navigation Window, they appear in the 

Internals List View.  

4. Go to Nodes and click on Cases. You have a new case node for each document (with the same 

name as that source). Click on a case node to see, in the Detail View what is coded there. You 

have coded at that node the entire source. 

Now that you have a Case node, you need not restrict the material on this case to just one source. 

When you later get more data about that case, you can code that data at the Case node. But for now, 

the task is to store information about the attributes of that case. 

 Note how often Attributes appear in the menus and dialogs. If you store information about the 

attributes of cases, this information will be useable in all Queries, òFindó processes and Reports.
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2. Using attributes and values 

If you know the attributes your respondents or sites will have (that is, the information youôll want to 

store about them), you can create them all now, with their values. But there is no need to ï attributes 

and values can be created as needed. You can individually create attributes and allocate the 

appropriate values in NVivo. Or, if you have substantial amounts of this type of information  

(e.g. in an SPSS or Excel file) it can be imported as a table.  

To create attributes and values 

1. In the Navigation Window, select Classifications>Attributes . Right click in the List View. 

From the Project menu, (or the Context menu, or the New button) select New Attribute . The 

New Attribute dialog box is displayed. 

2. Type in the name and, unless it is absolutely obvious what you are recording, a description of 

this attribute. 

3. Select the attribute Type (string, number or date) from the drop-down list.  

4. Click the Values tab to define the values for the attribute.  

 

5. To add each new value, click the Add button and enter value name and optionally, a 

description.  

6. Check the Default checkbox to specify which value will be allocated to new cases as a default 

(unassigned is usual.) 
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To assign Attribute Values to Cases 

If you know the information about an individual case, you can easily store it, or at any stage change 

it. 

1. In List  View, select the required case. From the Project menu or right mouse context menu, 

click Case Properties. 

2. Click the Attribute  Values tab and from the drop down menu for each attribute, choose the 

relevant value. Click OK . 

 

To view and use the Casebook 

Information about attributes is best displayed in a table. NVivo shows the Cases you create, and 

their values for each attribute , in a table called a Casebook. You can view the Casebook, import a 

table to it or export from it the information stored so far. 

1. From the Tools menu, select Casebook>Open Casebook. 

2. The Casebook appears in the Detail View. It may look very small if you have only one case 

with only one attribute! But as your data builds up it will fill up. The Casebook for the sample 

project looks like this. You can print it. 

 

3. Using the filter icons, you can change which rows appear. For example, to see only the 20-29 

year olds in your sample, filter on the column ñage groupò:  
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4. Case characteristics can be changed, when you get more information, or perhaps the 

circumstances of people are altered. At any stage, you can alter the value shown for any 

attribute of a case.  

 

To alter it to an existing value, select from the drop down list. 

 
 

To create a new value for a case, select the value in that cell and edit it ï if, for example, Anna just 

graduated!  

 

 Note  that long names of attributes and values will be shortened in the Ca sebook ð for efficiency, 

keep them as short as possible.  
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3. Importing attributes and values 
You can import information to a casebook from any program that handles tables (a spreadsheet, 

data base, statistics package, or just a table you make in MSWord.) 

An attribute table can be created ñoutsideò NVivo and imported.  You can create it by exporting 

attributes from a statistics package or spreadsheet. Or you can type up the table in spreadsheet or 

word processor software. If you have a lot of attributes and documents, this is more efficient than 

creating them in NVivo.  

Please check the Help files for more detailed advice on the formatting of tables and the format 

selected for import 

To create a table for import to a casebook 

1. Type a small table in any program that will create a table (e.g. Word or Excel), with the names 

of your cases down the side. The top left corner cell can be blank, or have any word in it (such 

as Schools or Interviewees). 

Make sure that the case names are the same as the names of case nodes in the  NVivo project 

that you want to give these attributes to.  If a case name is not recognized, NVivo will optionally create 

a new case node for it. If you donõt yet have those case nodes in your project, this may be what you 

want to do (itõs a quick way of creating case nodes). But if you have them slightly different, youõll get a 

lot of nodes!  

2. Type names of attributes as the headings of the columns. (Keep them brief.) 

3. Type into this table the names of the values for each case, under each attribute. If the attribute 

isnôt applicable, leave the cell blank. 

You will have a table that looks something like this (start small for a first try). 

 Gender Age Income 

Interview 1 Female Under 20 None 

Interview 2 Male 20-30 Middle  

 

4. Save that table in your table-making software, selecting the options for cells to be tab-separated, 

and the ñencodingò to be Unicode Text (*.txt).  

If you prepared your table in Word, check that there are no blank lines above or below the table, 

then on the top menu go to Table>Select>Table, then Table>Convert>Table to Text and choose 

Tabs for separation.  

Now select File>Save As and from Save As Type and Plain Text (.*txt) . When you close the 

window, Word asks you to specify File Conversion. Unclick the Windows (Default) and instead 

choose Other Encoding and scroll down to select Unicode. This matches the default setting for 

importing Casebooks into NVivo  

Or: if you leave the File Conversion at Windows (Default), the table will import so long as you 

change the File encoding setting in NVivo to US-ASCII. 

5. Save it somewhere you will find it again! 
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To import a table into your Casebook 

1. If you are unsure what you are importing, find and open the file you saved as plain text. It looks 

a lot less tidy than in its table format. But it has the same content as the table you saved. The 

cells are marked by tabs rather than neat lines. This is the version that NVivo can import. 

2. In your NVivo Project, choose Tools>Import Casebook. 

 

 

3. Click Browse to locate your tab separated 

table. 

4. Check that the File encoding setting is 

correct for the table you saved. 

5. Check the Options. You can ask NVivo to 

¶ overwrite existing values 

¶ create any attributes or cases your 

project doesnôt contain. 

 

6. Click OK.  Now open the Casebook and check what youôve done.       

 If the values didnõt appear as specified in the table you imported, itõs probably because you 
created those attributes prior to import, giving default values (usually not applicable) to the cases.  

If you didnõt ask to overwrite existing values, these will remain.  
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4. Using Sets 
This tutorial finishes with the simplest way of managing your data records in NVivo, by grouping 

sources and/or nodes in Sets.  

Whilst Sets are very easily made and used, they are also very effective quick ways to gather data in 

groups and ways into the most subtle and powerful searching processes (see Chapter 8). 

To make a Set 

There are many ways to create a set in NVivo and add items to it. Whichever you use, what is added 

is a shortcut to the items you select. 

1. To make a new, empty Set, click in the Sets folder in the Navigation Window, click on Sets.  

2. Select (from the Project menu or Context menu or the New button) New Set.   

 

3. Or, to make a new set with items in it, or add items to an existing set, go to the List V iew for 

those items (either sources or nodes) and select them. Then from the right mouse Context menu 

select Add to Set or Create As Set.  

 

4. Check the contents of a set by clicking on it in the Sets folder; the sources or nodes you put in it 

will show in the List View. Note, the icons are different ï these are shortcuts to the item. So you 

can put a source or a node in any number of different sets. 
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5. As a final exercise for this tutorial, think of useful ways you could group your documents and 

nodes for your projectôs purposes. In the example above, the researcher created a set for all 

coded sources ï a useful way of checking whether coding is proceeding as planned.  

 

For most qualitative projects, a useful set is of documents and/or nodes coding content that will 

contribute to your ñaudit trailò, your growing account of the project and how it is conducted. Visit 

the final chapter of Handling Qualitative Data to read about the task of doing a ñstock takeò of your 

writings about the project. This will be much easier if thereôs a pointer to each relevant document 

in a set called ñAudit trail documentsò. 

 

This concludes NVivo 8 Tutorial 3.  

Go to Chapter 3 of Handling Qualitative Data for advice on any of these research processes. 

You now have a project with data documents and information about their context, and have started 

managing those records in sets. Time to back up.  

In the next tutorial, youôll learn skills for discovery and handling of the ideas that come from the 

data. 
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NVivo 8 Tutorial 4:  

Editing and L inking ï Getting ñUp From The Dataò 

 
In this tutorial, you will work with just one document in your project, to explore the processes of 

ñtaking offò or ñgetting upò from the data. As you read the record, and discover new ideas, you will 

try different ways of storing these in the software.  

In Tutorial 5, the processes of coding will be described. Normally, researchers combine the storing 

of ideas with the creating of categories and doing coding ï but for early steps, it is useful to take 

them separately. In the following exercises you will: 

¶ Edit a document 

¶ Annotate it. 

¶ Write about it in a memo.  

¶ Link it to related data. 

¶ Draw your first ideas in a model. 

The first section of this tutorial, on editing, contains an introduction to the toolbars and icons that 

give access to NVivoôs processes. Unless you are very familiar with using toolbars, you will be 

helped by familiarizing yourself with the shortcuts and quick access routes to tasks you may wish to 

do often. 

Remember, there is almost always a choice of ways of asking NVivo to do something. As a 

reminder to select the processes that suit you best, the alternatives are noted in this section, in blue. 

Chapter 4 in Handling Qualitative Data is about the exciting processes in qualitative research 

involving discovery and exploration of ideas from the data. 

To review what you need to know about the different ways of storing ideas and different sorts of 

links, go to Help. 

Focusing on a document 

To start this tutorial, select a document you already have as a Source in your project.  

Print it out or browse it on the screen, and really read it. Make notes about it as you read. 

Now, go back to the start of that document. This time read the text very thoroughly, line by line. 

(As you find material that is interesting, conduct the exercise on ñTaking off from the dataò in 

Handling Qualitative Data, Chapter 4. In turn, the following exercises use each of the ways of storing 

ideas about the document discussed there.)  
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1. Editing and undoing 

To edit a document (or log or transcript) 

1. In the List View, create or select the source you wish to edit. Double click to open it in the 

Detail View below. 

2. This window allows you to write text, delete and edit it, as well as to annotate, create memos 

and (see next tutorial) code. 

3. Do some editing. The easiest way to create, add to or comment on the content of your data 

records is of course to edit them. You edit in NVivo very similarly to editing in a word 

processor. 

A note on toolbars 

If you are familiar with your word processorôs toolbars, or those in Outlook, you will find NVivoôs 

toolbars have icons for the same main processes and you can manage them similarly. Check the 

special NVivo functions and icons and then move to the next section! 

But if you are not used to using toolbars, take time to make these suit you. Qualitative research 

involves a lot of writing. Check that you know what each icon represents, by hovering over them. 

The Main  toolbar has familiar icons for cut, copy, paste options, and importantly, Undo!  (You can 

view all the icons and what they represent in the Add or Remove Buttons list.) 

 

These main menu options will apply to many processes, not just editing a data record. You can cut 

and paste a node, for example, or undo a change to a model.  

 Clicking the Undo icon wil l undo the most recent process. Clicking the dropdown arrow beside the 

Undo icon will show the last five processes you conducted. Select any to undo back to the selected 

process. 
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The Edit  Toolbar has icons for familiar word processing tasks. The first slots on this toolbar set text 

styles, font and font size. You may wish to make the toolbars shorter and use short cuts instead of 

icons. To do so, from the Add or Remove Buttons list untick any options you wish to hide. (As 

above, you can view the icons with their names by pulling down the Add or Remove Buttons list.) 

From the first slot on the Edit toolbar you can set the style for your text. 

 

 

 

If you use Headings when typing sources in Word, they will be 

imported with the source to NVivo.  

By setting heading level, you give NVivo information that allows 

it to show and autocode the content between headings. 

 

 

Click Customize at the end of any toolbar to hide icons you donôt want to use. But first check what 

they offer you! 

There are four further Toolbars specific to NVivoôs processes, Coding, Links , Grid  in tables, and 

ways of Viewing the data. Check how they represent items in the menus ï those most commonly 

used. 

You can drag the toolbars, as in Word, to relocate them (with their identifying names).  

         

 

For the next section, on annotating, try using the icons on the Links  and View toolbars. 
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2. Annotating sources 
Editing a data record is not always a desirable way of recording your ideas. If this is a record of an 

interview transcript, or a letter, you are unlikely to want to alter it with your comments, or distract 

from the voice of the respondent. For such commentary it is preferable to add an annotation that is 

linked to the text but does not interrupt it. Annotations can be searched using Find or Text Search 

Query, and when you do coding, your annotations will be kept live with coded text.  

 Words in an  NVivo annotation cannot be separately coded. So use annotations for ideas  that 

belong with the text annotated. A òbiggeró idea or interpretation requires a memo ð whose content can 

be coded like that of any other source.  

To add an annotation: 

1. In the Detail View, select some words that require an annotation. 

2. From the context menu select Links>Annotation>New Annotation.  

 

OR go to the Links  menu, or on the Links  toolbar, click the New Annotation icon. 

 

3. The selected text is highlighted. An Annotations tab appears at the bottom of the Detail View. 

Type your ideasé  

 

 

4. Make more annotations to this source. (Note any selection of text can have only one 

annotation). They will appear, appropriately numbered, in the tab. You can always go to an 

annotation to edit or delete it. And when you print the source, you can have annotations printed 

as endnotes. 

5. If you wish to hide your annotations, while you work in the Detail View, go to that View 

toolbar (or the View menu) and unselect View Annotations. 
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3. Writing a memo 
There is an emphasis in all qualitative methods on using memos to capture thoughts and insights 

you have when you are working through your data: (see Handling Qualitative Data, Chapter 4.) 

Memos are full status sources in NVivo. The program sees them differently from other sources only 

because you label them as memos. (The tutorial for Chapter 2 suggested a first memo called 

ñVolunteering and meò. If you made that, itôs a memo simply because you put it in the memos 

folder. If you are using the sample data, you will find several other memos in the Data folder for 

importing.) 

Any source ï including any memo ï can be linked to the content of any source. More on these ñsee 

alsoò links below. 

Any source or node (with one restriction) can have its ñownò Linked Memo, linked directly to that 

project item. These memos, ñownedò by a document or node, are optional, provided for the 

reflections on just that interview or concept.  

 The restriction?  A Linked Memo canõt itself have another Linked Memo. (This restriction 

protects you from endless tangles!)  

To make a Linked Memo for a source or node 

1. In List View , select the source or node for which you want to create a memo. 

2. From the Links  menu, choose Memo Link >Link to New Memo. 

 

 

Or right mouse to get the same options on the context menu. 

3. Name and describe this new memo, (as shown in Tutorial 2), and write your thoughts. 

Remember to insert date and time. Note that the sources that have linked memos show icons for 

these in the List View . 
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4. ñSee Alsoéò: ways of linking to related data. 
Qualitative research does a lot of linking ï as in most interpretative work, the researcher is often 

wishing to say ñSee also the data to be foundéò (Handling Qualitative Data, Chapter 4). Now the 

data records are becoming ñricherò, with your own ideas and the links to related material.  

NVivo provides a range of ways of linking for this purpose. As you reflect on your data, you may 

wish to place a See Also link to a new item, to particular words or images in existing data items or 

in a file that is on your computer (in any other software) or a website. Here we will show the first 

two of these. Explore other options using the online Help. 

You can make Memos that are not directly linked to an item, to record your growing ideas about 

themes and concepts that you want to go back and explore later on.  You can also of course keep 

those ideas in a notebook. But unlike the notebook, they can be linked directly to the text that gives 

you an idea, or the place you store it. This will matter when you wish to report and log the way you 

developed your analysis. 

To link from content of a source to a new or existing project item  

1. Open an internal in your project. (Or any memo, external, or node).  

2. Highlight some content you wish to link from.  

3. Right mouse click and choose Links>See Also Link>New See Also Link.  

 

 

Or get the same option from the Links  menu, or on the Links  toolbar, click the New See Also Link 

icon. 

 

4. In the New See Also Link window, specify what you want to link to. If it is a new document or 

memo, this will be created and opened.  
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To link to particular content of an item 

If your Option is to link to an existing item, you can select either to link to the whole or link to 

particular content (this is often more useful).  

To link to particular content 

1. Highlight the data you want to link to, then from the Context menu right click and click Copy. 

 
 

2. Select the data you want to create the link from, then from the Context menu choose Paste As 

See Also Link to make a ñSee Alsoò link to Selected Content. . 

 

 Note, you can make a link to selected content in the same document, useful if for example the 

speaker changed t heir mind on an issue later.  

To open the ñtoò item 

1. At any stage, you can go to the text you linked to from the anchor, now marked by pink 

highlighting of the text from which you made the link.  

2. Click in that anchor, and right mouse to select Links>Open To Item. 
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5. Drawing it ï the early uses of models 
Throughout qualitative research, models are widely used, with many ways of representing hunches, 

discoveries and theories. (Go to Handling Qualitative Data, Chapter 4 for suggestions for first uses of 

simple models as ways of sketching and exploring what you think you are seeing in the data.  

You may wish to explore these techniques more fully by jumping to the discussion of NVivoôs 

model tools in the tutorial for Chapter 7. Here, the goal is simply to become aware of the possibility 

of modeling your emerging ideas. 

To start a first model 

Models are made up of shapes and connectors. You start a model by adding these to a blank 

ñsheetò. You add new models just like any other project item ï from the List View, using the Main 

Menu (Project menu), the New button or the right mouse context menu. 

1. In Navigation View, click the Models button and click in the List View . 

2. On the Project menu, click New Model. 

3. In the New Model dialog enter a name and if you wish, a description. Click OK . An empty 

model is displayed in Detail View.  

4. Now add either empty shapes or project items to the model. There are many ways to do this: 

copy/paste, drag and drop, or use the Model menu or right mouse context menu. 

5. To connect two shapes, select them both and from the right mouse Context menu select New 

Connector. 

 

 

 

6. If you add Project items to the model, they are ñliveò: double click on them to open them in 
Detail View. 
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Shaping and changing the modelôs appearance 

Appearance does matter, when you are drawing a model to show (to yourself or your colleagues) 

what you are seeing in your project. But beware of how much time you can spend on cosmetic 

touches! 

1. To name your shapes and connectors, double click on them to go to their Properties. 

 

 

2. To color lines or fill shapes, go to the Format menu or toolbar. 

 

 

 

3. Select a connector, then from the Format menu, select Line and you can give your connectors 

style, weight and color. 
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Customizing the model space 

A final exercise in using the software concludes this tutorial. Use the menus to customize this 

modeling space to suit you. Models are a clear case for maximizing your screen ñreal estateò.  

 

1. Remember that you can undock the Detail View - click Docked in the Window menu. Now 

maximize the undocked window, to have your model able to take up the whole screen.  

 

2. From the View menu, 

select to hide the panels to 

left and right of the model 

ï the Model Shapes 

Palette and Model Groups.  

 

3. You can also Zoom in or 

out on your model. 

 

 

 

 

This concludes the NVivo 8 Tutorial 4. You now have data, ideas about your data and a rapidly 

growing project. Remember to back up the project file after you exit this tutorial! Go to Handling 

Qualitative Data, Chapter 4 for advice on any of these research processes. 

For most researchers, at this early stage in a project, the next task is to start gathering material 

according to topic. For this purpose, you need to code. If you are unfamiliar with qualitative ways 

of coding, go to Handling Qualitative Data, Chapter 5. In the next tutorial youôll learn many ways of 

doing coding in NVivo. 
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NVivo 8 Tutorial 5 : 

Nodes and Coding 

 
Nodes ï the containers for ideas and coding ï should be familiar by now. They were explained in 

Tutorial 3, where the exercises created nodes to hold references to all the material about a case. 

That tutorial also taught one sort of ñdescriptive codingò, the storing of attributes (e.g. gender) and 

assigning of the relevant value (e.g. female) to each case. Revisit that tutorial for techniques of 

doing this manually or by table import. 

But when qualitative researchers code, they are usually doing something interpretative, not merely 

descriptive. This tutorial shows techniques for doing qualitative coding. It introduces ways to create 

the categories for thinking about your data, to identify new categories and ideas from the data, and 

to gather material about those ideas.  

In it you will learn how to: 

¶ Create nodes from prior ideas; 

¶ Code at existing nodes; 

¶ Create nodes and code ñupò from meanings in the data; 

¶ Create and name new nodes ñin-vivoò, from the words in the data; 

¶ View coded data and its context; 

¶ Work with coded data, coding on to other nodes; 

¶ Auto-code data records that are structured, using headings. 

For advice about creating categories and coding, explanation of the differences between qualitative 

and quantitative coding and the purposes for which qualitative researchers use coding, go to 

Handling Qualitative Data, Chapter 5. 

For more detail about coding processes in NVivo , go to the online Help. 

Focusing on a document 
To start this tutorial, as with the previous one, you need to concentrate on one document in your 

project. 

It may be the document you worked with in the previous tutorial; itôs interesting (but not necessary) 

to combine writing and linking techniques with those of coding. If you want to move to a different 

document, read it through before you begin coding on computer.  Now, go back to the start of your 

document. 

The simplest goals of coding are to identify the categories for thinking about your data and to gather 

at a category all the data about it.  

In these examples, the document is one of the interviews in the sample project on Volunteering, the 

interview with ñAnnaò. You can conduct these exercises with any source (internal, external or 

memo) in your own project.  
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1. Making a node 
Where do the categories for thinking about your research come from? Researchers coding in 

qualitative research often create categories, ñdownò from their research questions and designs, 

before they start exploring the data. In NVivo, those categories and the coding you do are stored at 

nodes. 

The node areas 

In the Navigation View, click Nodes to view the different areas for nodes.  

These provide folders for: 

 

¶ nodes ñFreeò of organization  

¶ nodes in catalogs or ñTreesò 

¶ Cases (see Tutorial 3) 

¶ nodes for coding Relationships 

¶ Matrices (see Tutorial 9) 

¶ and to see nodes all in one list,       

All Nodes. 

 

 

The next tutorial covers Relationships and the managing of nodes in trees. Here you will code just 

at Free Nodes. 

To make a node 

1. Using a memo or model in NVivo, or if you prefer, paper, or a white board, sketch a beginning 

list of the categories your project is about ï topics or ideas about which you wish to collect data. 

(For example, in the Volunteering project you might be curious about what motivates volunteers 

or the images of volunteering.) 

2. Click on Free Nodes. And click in the empty List View .  

3. Just as for making new internals, there are many ways to make a new node. 

¶ From Project menu OR Context menu, select New Free Node.  

¶ OR use the New button, to create a New Free Node in This Folder.   

¶ OR use the fast key, Ctrl+Shift+A.  

 

 
 

4. Name the new node, and if you wish, add a description.  



Teach Yourself NVivo 8: tutorials by Lyn Richards      52 

 

 

5. Check the information in the List View . Note that the node is showing that it codes no Sources 

and (not surprisingly!) has no references to content. It is a useful habit to scan the nodes you 

create, watching for the ones that show no sources coded there, and wondering why they donôt 

have coding. 

 

6. Continue creating and naming nodes for any broad topics or concepts you expect that your 

project will require. If wish to change the properties of a node, select Free Node Properties 

from the Context menu. 

7. You changed your mind? Select Delete from the Edit  or Context menu ï or hit the Delete key. 

You may wish to continue reading and looking for data about the categories for which you already 

created nodes.  

Placing your nodes 

In Tutorial 6 you will learn the ways of moving nodes around, and using tree structures to represent 

their logical relations. If you wish to tidy the ñstarterò nodes youôve created, go to that tutorial for 

the techniques of cut, copy, merge and paste. 

 You may later wish to revisit the early ideas as they were represented by these fi rst nodes. 

They offer a way of recalling your early assumptions, what you thought then would be important, what 

the literature alerted you to. One way is to make a Set of all the nodes that you create at this 

starting -out stage of your project. But if late r you delete a node, of course its shortcut will be 

deleted from that set. Another way is to store a report of  your nodes at this stage, and later stages. 

(Go to Tutorial 6 for ways of reporting your nodes.) 
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2. Coding at an existing node 

To set the screen to suit your coding 

1. In the folder of Sources, select Internals and from the List View  select the document you wish 

to read and code. Double click to open it in the Detail View. This window, in which you 

annotated and linked a document in the previous tutorial, also offers several ways of coding.  

2. Click on Nodes>Free Nodes and the List View  shows your Free Nodes. 

3. Now set the screen to suit you. Most researchers when coding wish to see all their nodes 

displayed beside the content being coded. From the View menu, select Detail View>Right, to 

see the panels of the Navigation Window vertically. 

 

4. The Coding toolbar offers ways of selecting nodes and buttons for coding functions. You may 

wish now to move it to the bottom of the Detail View. 

 

5. Hover over the icons, or go to the end of the toolbar to check the names for each option. You 

may wish to hide some of them ï but first, check what they do! One will be wanted often: the 

green tick over lines of text that says Code. 

Coding from different sources 

As well as coding from textual documents, you can also code the data in your externals, memos, 

logs and transcripts, and directly from your images, audio and video files.  

When coding text, select the exact text you want to code by clicking and dragging the mouse to 

select the required area. 
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When coding part of an image, select the section you want to code by clicking and dragging the 

mouse over the image to select the required area.  

 

When coding audio or video data directly, select the section you want to code by clicking and 

dragging the mouse on the timeline to select the required section.    

 

These selected sections of data can then be coded using the methods described below 

 

Now you are ready to code at your existing node, in any of several ways. You can drag and drop, 

use the menus or use that coding bar. 

 

To code by drag and drop at an existing node 

1. Select some text that you wish to code at the Free Node you have created.  

Note: Only whole rows from transcripts and logs can be coded by drag and drop.  To code 

specific text from these, use one of the other methods of coding. 

2. Drag the text onto the node. (the mouse icon shows that it is being ñdraggedò and then that it has 
ñdroppedò what it was dragging.) 
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To code at an existing node using the menus 

1. Select some more data that you wish to code at an existing node. 

2. From the right mouse Context Menu or the Code menu, select Code>Code Selection at 

Existing Nodes. Note the other options: to code at a new node or the node currently showing in 

the coding bar. 

 

3. NVivo asks what node do you wish to code at, by offering the Select Project Items box. Select 

the node, or if you wish more than one node, and click OK .  

4. The node selected appears in the slot for a current node name in the Coding toolbar.  

 

To code further content at this node, select some more data and click the Code icon.  

To code with the coding bar at an existing node 

The Coding Bar can be used directly. Check if this suits your style. 

1. Select some more data that you wish to code at an existing node. 

2. Check what node is in the slot in the coding bar. When you click the Code button, it will code at 

the node showing there. 

 

 

3. To select a different node ï or nodes ï to code at, set the coding bar to Code At| Name, and 

click the [é] button to Select Nodes. 

4. From the Select Project Items box select the node or any number of nodes at which you wish to 

code this text. 

5. Click . Note that if you change your mind, the Uncode icon is the next on the bar! 
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Those prior categories will probably not suffice for what you are now seeing in the data. 

Researchers sometimes start this way.  

But almost always, most categories are discovered and created ñupò from the data, as they read and 

interpret data sources. This is the most usual form of qualitative coding. 

You could of course create new nodes as you discover new categories, and continue as above, 

making the nodes first, and then coding at them by dragging the text to them or selecting them and 

clicking Code. 

But NVivo allows you to combine these processes, making the nodes and coding at them as a single 

task. As you work with your data, youôll make a lot of nodes! 

This is the next task. If you are new to qualitative coding, you may like to follow the steps in 

Chapter 5 of Handling Qualitative Data. 
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3. Creating new nodes ñupò from the data 
As you read your sources, you may see a category ñemergeò.  You can make the node and do the 

coding as one task, either with the menus or with the Coding Bar. 

To create a node by coding (using the menus) 

1. Highlight some data you wish to code.  

2. From the Context Menu, select Code Selection at New Node 

3. In the New Free Node box, type a name for this node ï the category or theme - and, if you 

wish, a description. Click OK .   

 

4. The node is created and the coding done. Your new node appears in the Free Nodes List View 

and in the Name slot on the Coding bar. 

5. If you wish to place the new node in another node area, use Cut and Paste as described in the 

next Tutorial. 

 The process you just conducted is often the most exciting and important one early in a  project. 

Itõs worth becoming very familiar with this swift task, so the creation of a node and coding of data at 

it feels like thinking aloud.  

Note there is a shortcut ð Ctrl+F3 ð for coding a selection at a new node, and when the New Free 

Node box appears, if you wish to place your new node in Free Nodes, you need only type the name and 

press return ð the rest is done for you.  

Try working through some rich data, making new nodes as they occur to you, using the shortcut, type 

name, press return.  

To create a new node whilst coding (using the Coding Bar) 

1. Highlight some data text you wish to code.  

2. On the Coding Bar, check that the slot is set to Name. 

3. Type the name for this node.  (If a name is in the slot, highlight and type over.) Select the node 

area it will be in. 
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4. Press Return (thatôs fastest!) or click Code.   

5. The node is created and the coding done. 

To create an In Vivo node and code at it 

You can also create a new node by naming it with the word(s) in the text you are coding.  

Note: InVivo nodes can only be created using textual data 

This is called ñin vivoò coding, a technique very important to researchers who wish to record the 

categories emerging from their data (see Handling Qualitative Data Chapter 5.) Itôs useful when the 

text provides specially suggestive or meaningful concepts. For example, in the Volunteering 

project, Anna used the term ñself worthò to explain motivation to volunteer, a new idea which you 

might like to store. 

 When you do in vivo coding, you name the new node with all the text you selected. Make the 

selection brief and relevant ð long node names are awkward to use.  

 

1. Highlight a word or a few words in the text with which you would like to name a node.  

2.   Click the ñCode In Vivoò button on the coding bar, (or use the Code or 

Context menus) 

3. The node is created (in Free Nodes) and the coding done. Your new node appears in the Free 

Nodes List View and in the Current Node slot on the Coding bar, so you can code again at that 

node immediately.  

4. Note that a shortcut is Ctrl+F8. Create a new node using that shortcut.  
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4. Viewing your coding  
There are many reasons why you may wish to see what coding youôve done, or what content is 

coded at a node ï for example, to review your coding, compare with a colleagueôs coding, browse 

to check what else is coded in this source at that node, or simply to get back to coding where you 

left off.  

NVivo provides two ways to view your coding as you work. Both are on the View toolbar (and the 

View menu and right mouse Context menu).  

When you are in the Detail View of a source or node, Highlight  and Coding Stripes are available.  

 

To Highlight Coding  

 

1. In the Detail View of the document you coded, click Highlight. 

(or select Highlight from the View menu). 

2. Select the option you want 

 

 

3. In the Select Project Items window, select the node or nodes you are interested in. The coded 

text is highlighted yellow.  

 

Why would you select Coding for All Nodes? This will show you everything that has been 

coded ï and thus everything you havenôt coded yet ï a useful way to see how your coding is 

progressing! 
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 The whole document may be highlighted when you select Coding for All Nodes . Why? 

Probably, as in Annaõs interview, the entire content is coded at a Case node.  To exclude Case 

Nodes (or any other node type you donõt want), in the left pane of the Select Project Items 

window, click Automatically select subfolders, and then select all the folders whose nodes you want 

highlighted.  

.  

To use Coding Stripes  

NVivo will show in the right margin of a Detail View (source or node) colored lines that show 

where content is coded at up to seven nodes, and a grayscale line that shows the Coding Density for 

that content. 

1. In the Detail View of the document you coded, click the icon for Coding Stripes, or select from 

the View menu. 

 

2. Select the Selected Itemsé option and the Select Project Item box will appear.  

3. Select which nodes you are interested in and click OK . The stripes appear for those nodes. If 

you code some more, at the nodes for which you are showing stripes, the lines will update. 

4. In Detail View, the coding stripes appear where there is coding at each selected node. Each 

selected node will be marked by its specific colored line throughout Detail View, so you can 

scan for coding at each.  
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5. Hover over any stripe to see the nodeôs folder and full name.  

6. Right mouse to select to Highlight Coding  at that node throughout the Detail View, to Open 

Node, to Uncode or Hide Stripe. 

Explore the options so you can use the stripes strategically. Two tips may assist: 

¶ To use coding stripes rapidly to view current coding, select to show Nodes Recently Coding 

Item. 

¶ Show stripes for just a Selection to focus on nodes coding that passage. Most sources or 

nodes will have coding from a large number of nodes, but if you make a small selection, you 

will most clearly see what codes it. 

Shadow Coding  

When viewing coding stripes on an audio or video source, you may see a combination of solid 

stripes and variegated stripes.  These variegated stripes are known as shadow coding and they show 

the coding done on the associated data, e.g. if a section of video has been coded, the associated 

transcript entry will be shadow coded.  

 

 


